Page 1 of 2

Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Tue May 14, 2019 3:40 pm
by Enzotron
I'm not saying that this is ready to go on an AMD HackMac, but I'm interested to know if anyone has tried it?

UPDATE (May 15): 10.14.5 is ready to go!
[ See Reply by Chi-Hu Park for details:
viewtopic.php?f=55&t=7407#p48049 ]


Isn't 10.14.5 supposed to introduce some significant shifts towards OS X 10.15 (going by various YouTube reports)?

Anyhow, Here's a link to Apple's new 10.14.5 page I came across:
https://support.apple.com/kb/DL2001?locale=en_US

Re: Just a Heads-up...Looks Like Apple released 10.14.5  Topic is solved

Posted: Wed May 15, 2019 1:01 pm
by Chi-Hu Park
AMD Vanilla Clover Patches for 10.14.5 were updated. It is perfect to update 10.14.5 through software update.
https://github.com/AMD-OSX/AMD_Vanilla
Thanks, AlGray!!

CPU: AMD Ryzen 7 2700X
Mobo: Asus X370 pro
Video: Radeon RX 470 4GB
RAM: 32GB
Post Merged
USB port limit patch for 10.14.5. were also updated. Remove USB port limit patch for 10.14.4 and Whrite these 4 lanes.

1. com.apple.iokit.IOUSBHostFamily 83FB0F0F 83FB3F0F
USB port limit patch #1 10.14.x modify by DalianSky(credit ydeng) 10.14.x
2. com.apple.iokit.IOUSBHostFamily 83E30FD3 83E33FD3
USB port limit patch #2 10.14.x modify by DalianSky(credit PMHeart) 10.14.x
3. com.apple.driver.usb.AppleUSBXHCI 83FB0F0F 83FB3F0F
USB port limit patch #2 10.14.x modify by DalianSky(credit PMHeart) 10.14.x
4. com.apple.driver.usb.AppleUSBXHCI 83FF0F0F 83FF3F0F
USB port limit patch #2 10.14.x modify by DalianSky(credit PMHeart) 10.14.x

https://www.tonymacx86.com/threads/moja ... ch.277166/

Enjoy!!

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Wed May 15, 2019 1:20 pm
by Shaneee
They have indeed been updated. Both FX and Zen.

Image

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Wed May 15, 2019 2:36 pm
awesome! been waiting for the right patches and confirmation.

will update this weekend.

Also, do the vanilla patches for 10.14.5 replace all the current drivers?
I had issues with my RX 580 before where all video playback were choppy on 1440p retina, a few days ago with my current drivers/kext, everything working perfectly including 4k 60fps playback.

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Wed May 15, 2019 2:50 pm
by Shaneee
@[email protected], The patches only allow CPU support. They shouldn't relate to GPU drivers. Apple have however seemed to have updated some.

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Wed May 15, 2019 5:48 pm
Shaneee wrote:@[email protected], The patches only allow CPU support. They shouldn't relate to GPU drivers. Apple have however seemed to have updated some.
I see. Thanks for the info; so it shouldn't be any issue with my current drivers then..

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Thu May 16, 2019 10:00 am
by usurai
I've applied the patch and updated system to 10.14.5, but Processor in About This Mac is still Unknown. My processor is Ryzen 1600.

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Thu May 16, 2019 11:26 am
by Taillis Mariquito
usurai wrote:
Thu May 16, 2019 10:00 am
I've applied the patch and updated system to 10.14.5, but Processor in About This Mac is still Unknown. My processor is Ryzen 1600.
You can change CPU name following this tutorial viewtopic.php?p=20798#p20798

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Fri May 17, 2019 9:04 am
by usurai
Taillis Mariquito wrote:
Thu May 16, 2019 11:26 am
usurai wrote:
Thu May 16, 2019 10:00 am
I've applied the patch and updated system to 10.14.5, but Processor in About This Mac is still Unknown. My processor is Ryzen 1600.
You can change CPU name following this tutorial viewtopic.php?p=20798#p20798
That works! Thx a lot.

Re: Just a Heads-up...Looks Like Apple released 10.14.5

Posted: Fri May 17, 2019 2:50 pm
by Trevor30
When i updated the system from 10.14.1 to 10.14.5 the screen will be red and yellow. I use patched clover from this site https://github.com/AMD-OSX/AMD_Vanilla
I try RadeonDelnit but no change.

Solved: I forgot to delete the kcsuffix=amd of the boot flags.