Page 1 of 1

10.14.4 USB 2.0 Not working

Posted: Tue May 14, 2019 1:35 am
by Tyrael2003
UPDATE 20190521

I found another way to solve my problem, maybe this solution is not what you are thinking.
Considering the USB 2.0 is still not working, and the USB 3.0/3.1 works just fine, I decide not to make further endeavor on USB 2.0.
I brought a cable which is an adapter between usb 2.0 and 3.0, it is like this picture.
IMG_5517.JPG
And I connect the usb 2.0 port to the usb 3.0 port of my motherboard.
It then works successfully.
Now my bluetooth is working because it needs a onboard usb 2.0 port.
Hope my experience would bring you some ideas.
屏幕快照 2019-05-21 11.14.43.png

Hi Everyone

I am asking for instruction for my newly installed system.
I fellow the instruction:https://vanilla.amd-osx.com/ to install my macOS, everything works fine except all USB 2.0 ports. It seems that the USB 2.0 controller is not recognized by the system. I tried this instruction:viewtopic.php?f=24&t=4986([NEW] NATIVE USB SUPPORT [RYZEN CPUS ONLY]), but did not work as well.
Is there anyone who is facing the same problem?
Is there any kind person who would like to help me with the USB 2.0 ports?
Thank you very much!!!!

UPDATE(20190518): Updating to 10.14.5 is also tried, the system works fine with new patches and nothing changes. All functions except usb 2.0 ports are fine...

Motherboard: Asrock X370 taichi
CPU: Ryzen 1700X
OS: 10.14.4

Re: 10.14.4 USB 2.0 Not working

Posted: Tue May 14, 2019 3:36 am
by ToFailToWin
Would you mind uploading your config.plist?

Re: 10.14.4 USB 2.0 Not working

Posted: Tue May 14, 2019 5:31 am
by Luoboutou
try the new config from here.https://github.com/AMD-OSX/AMD_Vanilla

Re: 10.14.4 USB 2.0 Not working

Posted: Tue May 14, 2019 7:50 am
by Tyrael2003
@ToFailToWin, Thanks for replying. The config.plist has been uploaded. Please help, thank you!
Post Merged
@Luoboutou, Thank you for reminding. However, the system was installed yesterday, the config.plist has been the newest one. By the way, I saw patches.plist in the same folder, would you please tell me how to use it?

Re: 10.14.4 USB 2.0 Not working

Posted: Wed May 15, 2019 6:40 pm
by Flexarius
Hi,

i have the some problem like Tyrael2003. USB 3.0 and USB 3.1 are working, USB 2.0 not. My mouse and keyboard are connect to this 2 USB 2.0 ports.

New Vanilla Install method

Asus Crosshair VII Hero+2700X

Re: 10.14.4 USB 2.0 Not working

Posted: Thu May 16, 2019 11:56 pm
by xgamespati
Flexarius wrote:
Wed May 15, 2019 6:40 pm
Hi,

i have the some problem like Tyrael2003. USB 3.0 and USB 3.1 are working, USB 2.0 not. My mouse and keyboard are connect to this 2 USB 2.0 ports.

New Vanilla Install method

Asus Crosshair VII Hero+2700X
maybe u can put genericusbxhci kext and usbinjectall on efi/clover/other

Re: 10.14.4 USB 2.0 Not working

Posted: Fri May 17, 2019 11:55 pm
by Tyrael2003
@xgamespati, tried, but not working, when putting genericusbxhci kext and usbinjectall on efi/clover/other all the usb ports will not be recognized by macOS, however, interestingly, the usb 3.0/3.1 ports still works and usb 2.0 ports still not working.
Post Merged
xgamespati wrote:
Flexarius wrote:
Wed May 15, 2019 6:40 pm
Hi,

i have the some problem like Tyrael2003. USB 3.0 and USB 3.1 are working, USB 2.0 not. My mouse and keyboard are connect to this 2 USB 2.0 ports.

New Vanilla Install method

Asus Crosshair VII Hero+2700X
maybe u can put genericusbxhci kext and usbinjectall on efi/clover/other
Updating to 10.14.5 is also tried, the system works fine with new patches and nothing changes. All functions except usb 2.0 ports are fine...

Re: 10.14.4 USB 2.0 Not working

Posted: Mon May 20, 2019 1:08 am
by xgamespati
Tyrael2003 wrote:
Fri May 17, 2019 11:57 pm
@xgamespati, tried, but not working, when putting genericusbxhci kext and usbinjectall on efi/clover/other all the usb ports will not be recognized by macOS, however, interestingly, the usb 3.0/3.1 ports still works and usb 2.0 ports still not working.
Post Merged
xgamespati wrote:
Flexarius wrote:
Wed May 15, 2019 6:40 pm
Hi,

i have the some problem like Tyrael2003. USB 3.0 and USB 3.1 are working, USB 2.0 not. My mouse and keyboard are connect to this 2 USB 2.0 ports.

New Vanilla Install method

Asus Crosshair VII Hero+2700X
maybe u can put genericusbxhci kext and usbinjectall on efi/clover/other
Updating to 10.14.5 is also tried, the system works fine with new patches and nothing changes. All functions except usb 2.0 ports are fine...
all my usb 2 working, but all usb 3 not working on mojave 10.14.5, im using asrock a320m hdv + ryzen 2200g with gtx 6501 1gb msi

Re: 10.14.4 USB 2.0 Not working

Posted: Tue May 21, 2019 3:02 am
by Tyrael2003
xgamespati wrote:
Tyrael2003 wrote:
Fri May 17, 2019 11:57 pm
@xgamespati, tried, but not working, when putting genericusbxhci kext and usbinjectall on efi/clover/other all the usb ports will not be recognized by macOS, however, interestingly, the usb 3.0/3.1 ports still works and usb 2.0 ports still not working.
Post Merged
xgamespati wrote: maybe u can put genericusbxhci kext and usbinjectall on efi/clover/other
Updating to 10.14.5 is also tried, the system works fine with new patches and nothing changes. All functions except usb 2.0 ports are fine...
all my usb 2 working, but all usb 3 not working on mojave 10.14.5, im using asrock a320m hdv + ryzen 2200g with gtx 6501 1gb msi
That is interesting, I think we should exchange the files in efi/clover/other to find what is wrong with each other.

My clover/other files is attached here.
Other.zip