Welcome to AMD OS X

Why not register now to gain full access.

Help with AMD OS X after installation.
User avatar
by: golden007
#42476
OS: MacOS 10.13.3 / Windows 10
CPU: AMD Ryzen 5 1600 @3.2 GHz
MOBO: ASROCK AB350 PRO4
GPU: MSI RX 560 4GB 128-bit GDDR5
RAM:16GB DDR4 @ 2933 MHz
WIFI: Fenvi FV8303 Dual Band 2.4/5.0 with BT4.0

Windows works all fine. In MacOS, under System Report - No USB details, No BT details

But all USB ports are working, if I plugin any USB based data-dongle like 32 GB Sandisk/Any-other, MacOS will recognize instantly and with mount it. BT on other hand is not working at all. Tried all USB based BT dongles, no luck.

Need help on KEXTs to see USB and BT details listed in System Report - Which h/w, which Kexts, and Steps... please point me to right direction.
Post Merged
Was able to get USB details under System Report with updated 'SPUSBReporter.spreporter' file. So now only issue is BlueTooth.
When I try any bluetooth USB dongle, USB System Report displays what has been connected on USB port (brand name etc) but BT-System Report still shows - No Info.
The FENVI Dual Wifi with BT4.0 (PCIe) is completely absent as well.

 Advertising

User avatar
by: AlGrey
#42482
check my signature
User avatar
by: golden007
#42487
Thanks @Algrey... but I couldn't find anything for Bluetooth in your posts. All USB port are working for me, and support any dongle but bluetooth. Help me on bluetooth via PCIe or Usb Dongle setup, which h/w, kext ver and steps.
Post Merged
@AlGrey, Just for info - The FENVI (FV8303) Dual Wifi with BT4.0 (PCIe) which is absent in MacOs is working fine in WIN10 - i.e. BT4.0 along with dual WiFi works in windows.

But because this PCIe card gets power for BT portion via mini usb cable - the USB under MacOS - system report does say 'Bluetooth HCI' and that's it, nothing else, nothing under bluetooth info, no BT in system preference.

I tried disconnected the mini usb for pie card, so in macOS that 'bluetooth HCI' is gone, then I tried 10.12.6 KEXTs using kEXT Util 2.6.6. after disabling SIP, but still 'No Info' in system report and nothing for BT in system pref. Tried 3 different USB-BT dongles none of them show up.
You do not have the required permissions to view the files attached to this post.
User avatar
by: AlGrey
#42491
make a clean install without applying any BT or USB patches and it will work with my usb patch ...if the chipset is compatible with macOS... not sure it is
Post Merged
indeed it's not : it's a AR3012 BT chip

If you have the coding skills:
Code: Select all
https://www.tonymacx86.com/threads/atheros-ar9462-wifi-ar3012-bluetooth-support-for-high-sierra.233902/
https://github.com/RehabMan/OS-X-Atheros-3k-Firmware
https://wireless.wiki.kernel.org/en/users/drivers/ath3k
User avatar
by: golden007
#42492
@AlGrey, Thanks... I think its a matter of finding the right Bluetooth PCIe Card or USB dongle... so I will keep trying different ones and update. But except the bluetooth everything else under MacOS is working fine - I mean all the USB ports and hence any USB Mouse, Any USB keyboard, and I also have WIFI dual band via a USB dongle working.

It is just the without BT it seems half cooked :shifty: - anyway thanks for your suggestion, will update when I make it work
Post Merged
@AlGrey, BTW how did u figured its AR3012 BT??? this MOBO doesn't have any BT so I tried Fenvi 8303 which is a Qualcomm Atheros pcie card - AR5BMD222 - https://wikidevi.com/wiki/Atheros_AR5BMD22
Post Merged
@AlGrey, Thanks :) your post did gave some idea... I figured Fenvi 8303 PCIe card = Qualcomm Atheros AR5BMD222 = AR9642 and so AR9462 fix-Kext did made the Wifi to work on MacOS now. Earlier I was using a TPLINK Dual Wifi USB, but now same Fenvi 8303 is giving me dual wifi usage... but still no sign of BT4.0.
User avatar
by: AlGrey
#42498
cool.. the wifi is AR9642 .. the BT is AR3012 (found from the vendor and Device id from the screenshot you shared)
User avatar
by: golden007
#42634
@AlGrey, Hi... am not happy without BT... so looking at my signature minus Fenvi 8303 (that you figured is actually AR9642+AR3012), let me know which pcie card or dongle will work. I mean I am still in phase where I can return the Fenvi 8303 pcie card, so please tell me the new h/w (plus kext etc) which is proven to work (I mean suggest me one that you think/know will work on my combination of h/w). Thanks in advance. BTW as you suggested I did refresh OS (fresh installation) and didn't do any experiment this time except to make AR9642 (wifi) to work.
User avatar
by: AlGrey
#42650
idk I use a cheap $4 CSR8510 A10 usb dongle from eBay for BT. Best wi-fi/bt cards are the ones with Broadcom chips .. You can use google and figure this out ..
Code: Select all
https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/
User avatar
by: golden007
#42653
@AlGrey, Thanks for the info. Any particular KEXT or set-of-KEXT for your dongle? I will try the same dongle and update. Also one more trial with with Fenvi-T919 - arriving next week.
User avatar
by: AlGrey
#42668
golden007 wrote:
Thu Sep 13, 2018 11:26 pm
@AlGrey, Thanks for the info. Any particular KEXT or set-of-KEXT for your dongle? I will try the same dongle and update. Also one more trial with with Fenvi-T919 - arriving next week.
no it's all native. The fenvi t919 looks like a hit or miss. let me know if it works.
How did you find us?

Hi Shane, I found you via videos on YouTube. I h[…]

OsxAptioFixDrv Error

I had the same issue, and solved it with the same […]

So it is workd ?

INTEL or AMD?

intel is more stable .. amd is also cool but its l[…]

AMD OS X Advertisements