Welcome to AMD OS X

Why not register now to gain full access.

#37629
Hello all!
So I have been trying to install Mac OS High Sierra in my AMD PC.
My specs are:
FX 8370-GTX 1060-12 GB DDR3 on Gigabyte GA-78LMT-USB3 motherboard. (Please refer to my signature for a detailed configuration list or feel free to ask me anything else.)

I downloaded the v3 image from the downloads section and I am following this tutorial: https://www.youtube.com/watch?v=7zetiocqdWU
As per the video, I made a bootable USB with TransMac (using the restore with image option) and then changed SATA type in BIOS to AHCI.
I can boot comfortably to Clover (the grey screen with all the options?) and after adding the nv_disable=1 flag in the options menu, I proceed to boot from AMD High Sierra in Clover.
It starts with a single small horizontal cursor after which I can see the "does printf work?" message. After pressing y and/or enter the setup proceeds to a stripped down version of a BIOS or the Boot Menu with options like:
Continue
Language
Boot Manager
and so on.
If select 'Continue', I get a screen full of red texts, with something like "!!!! X64 Exception Type". Also if I navigate to the Device Manager/Boot Manager I see two options EFI USB and EFI USB 1 and no matter what I choose, it proceeds to the same X64 Exception error.

Please note:
  • I have come across another such post in the forums, but the solution points to something that has to be done AFTER the installation, where as I am stuck at first step!
  • I have tried disconnecting my windows drives and removing two of my three RAM sticks, but to no avail.
  • Also I went ahead and disabled virtualization in BIOS as well, since some person said doing that solved their problems.
  • I have allocated a whole 500 GB HDD for Mac OS so partitioning and other related problems cannot be an issue.

 Advertising

#42381
Hey guys, I had the same error but on an ASRock MB. I managed to get past it by resetting all my bios settings to default and then configuring the following:

Virtualization: off
Serial Port: disabled
USB 3/2/Legacy: all enabled
SATA: AHCI

I know it may not be one-to-one since you’re on a Gigabyte board but I hope it helps! Oh, and I remade my flash drive with the V2 installer before reconfiguring. I also booted the USB through boot manager (F11 on my board) instead of just allowing it to be default
#44952
disable "CSM support" and boot your bootable device via UEFI mode, not the other one.
#45136
m2ma wrote:
Sat Jan 26, 2019 5:30 pm
i don't have "CSM support" in boot, what else can i do?
CSM support will allow u to load Legacy emulation, which sometimes causes confusion to install Hackintosh...but its ok to try to enable/disable it.
I just load my bootloader via UEFI and its working, if non-UEFI (Legacy) I got that red colored text on my screen, my experience. Try check ur PC support UEFI or not. Or try another installer like this one probably support for Legacy.
viewtopic.php?f=23&t=2948#p33500
#45286
Mike T wrote:
Sat Jan 26, 2019 8:54 pm
m2ma wrote:
Sat Jan 26, 2019 5:30 pm
i don't have "CSM support" in boot, what else can i do?
CSM support will allow u to load Legacy emulation, which sometimes causes confusion to install Hackintosh...but its ok to try to enable/disable it.
I just load my bootloader via UEFI and its working, if non-UEFI (Legacy) I got that red colored text on my screen, my experience. Try check ur PC support UEFI or not. Or try another installer like this one probably support for Legacy.
viewtopic.php?f=23&t=2948#p33500
i have downloaded "AMDHS_INSTALLER v2 CLOVER EDITION" and still i have the X64 Exception Type... error, my system is not supporting the UEFI how can i load it for install on Legacy?
Post Merged
Asus 1015T and CPU is AMD NILE V105 with 4 gb of ram

Hi, I was trying to install High Sierra through vi[…]

I followed the video-instructions step by step, ho[…]

Excellent work! Would you be able to provide your […]

hp elitebook 745 g3 El Capitan

SPEC: AMD PRO A8 -8600B with AMD Radeon R6 Graphic[…]