• [HIGH SIERRA]!!!! X64 Exception Type in red colored text when attempting to begin installation

Please remember to read and follow the rules here.

Please Donate or visit my Amazon Wishlist if you've found the website useful. Thanks.

#37629 by AnindyaChakravarty
Mon Feb 12, 2018 5:38 pm
Hello all!
So I have been trying to install Mac OS High Sierra in my AMD PC.
My specs are:
FX 8370-GTX 1060-12 GB DDR3 on Gigabyte GA-78LMT-USB3 motherboard. (Please refer to my signature for a detailed configuration list or feel free to ask me anything else.)

I downloaded the v3 image from the downloads section and I am following this tutorial: https://www.youtube.com/watch?v=7zetiocqdWU
As per the video, I made a bootable USB with TransMac (using the restore with image option) and then changed SATA type in BIOS to AHCI.
I can boot comfortably to Clover (the grey screen with all the options?) and after adding the nv_disable=1 flag in the options menu, I proceed to boot from AMD High Sierra in Clover.
It starts with a single small horizontal cursor after which I can see the "does printf work?" message. After pressing y and/or enter the setup proceeds to a stripped down version of a BIOS or the Boot Menu with options like:
Boot Manager
and so on.
If select 'Continue', I get a screen full of red texts, with something like "!!!! X64 Exception Type". Also if I navigate to the Device Manager/Boot Manager I see two options EFI USB and EFI USB 1 and no matter what I choose, it proceeds to the same X64 Exception error.

Please note:
  • I have come across another such post in the forums, but the solution points to something that has to be done AFTER the installation, where as I am stuck at first step!
  • I have tried disconnecting my windows drives and removing two of my three RAM sticks, but to no avail.
  • Also I went ahead and disabled virtualization in BIOS as well, since some person said doing that solved their problems.
  • I have allocated a whole 500 GB HDD for Mac OS so partitioning and other related problems cannot be an issue.

This topic has 2 replies
You must be a registered member and logged in to view the replies in this topic.