Welcome to AMD OS X

Why not register now to gain full access.

AlGrey wrote:@HonorGoG, use this clover version of this image : viewtopic.php?p=33500#p33500
I believe XLNC used 10.12.6 as the base for the V2 installation. I hope he does the V3 update on 10.13 to avoid the NVMe issues. But basically, this prevents my Samsung 960 EVO SSD from being seen. I think I tried installing with it in the past but it was never able to see that drive. I'll give it a try tonight and see how it goes. Since the drive is actually formatted this time, maybe it'll show up.


Yes you only want to use the clover from this image as you already installed the OS.
@AlGrey: I'm not sure if I did this correctly but...
  • Mounted both EFI folders on my USB and the AMDHS_Installer_v2_clover disk image.
  • Copied over EFI/CLOVER from AMDHS_Installer_v2_clover disk image to the EFI partition on my USB.
  • Booted system.
Loaded right up and I did see the RadDeInit option on the Config choice but it is not seeing my Samsung 960 EVO NVMe drive. When I went into Disk Utility, it can see it but it's not on the Clover bootloader screen. Any idea how to get that to show up? I know the AMDHS_Installer_v2_clover image was built on 10.12 which lacks native NVMe support. That's the reason I didn't use it earlier as it couldn't see my SSD.
bbmatias3 wrote:
Wed Jan 10, 2018 3:04 am
if you can boot put
whatervergreen + lilu in system, library , extensions
then use kext utility
then reboot
for some reason ryzen doesnt like those kext in clover
(from my experience)
HonorGoG you don't have to do that. The problem is the theme. Rename "OLDCLOVER" back to "CLOVER" and change the theme from "noname" to "BGM" in the config.plist. The options should now be there at boot.
@AlGrey: The config.plist within the USB EFI/CLOVER folder had a theme of "HighSierra" so I manually changed it to "BGM". I then booted off the USB and still ended up with the original theme. Perhaps it's not installed. I'll try Clover Configurator tonight. I built the USB with the HighSierraAMD_V2 image. I noted that the AMDHS_Installer_v2_clover installer has a config.RadDeinit.plist within EFI/CLOVER that is lacking in HighSierraAMD_V2.

On a side note and as an FYI, I still cannot boot into my Hackintosh to execute the "first run wizard" but I do have a functional MacBook Pro running 10.13.2 which is my work machine. I use it to do all of this manipulation to the USB before moving it and attempting to boot on the Hackintosh.
AlGrey wrote:@Hyde, sorry the answer was for HonorGo (Rx 560).
Your HD5850 is pretty old doesn't support UEFI mode (only legacy bios).. Try to boot with bootflag -radoff and set injectATI OR only with injectATI without -radoff (but with whatervergreen + lilu in /EFI/CLOVER/kexts/Other or 10.13)
Do you know if going back to Sierra the HD5850 could work properly?

If not, what GPU do you recommend for optimal acceleration over High Sierra? I could find a list of low end GPUs that resumes the overall functionality on this OSX version.
@Hyde, Yes it should be able to get acceleration in Sierra.
Post Merged
@HonorGoG, then just copy the /EFI/CLOVER/Themes folder from XLNC's image in the "OLDCLOVER" renamed clover. Theme should be in it (will see the folder name inside that directory)
RE: IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

I had the same problem for days. Nothing seemed to work. Always the same error message. The solution came when I paid lots of attention to the BIOS settings, particularly the Secure Boot settings. They should be disabled completely to install HighSierraAMD_V2 . There are several other importants BIOS settings mentioned elsewhere that should be heeded. I'm not familiar with your MB's BIOS, so research and experiment with yours. Good luck.
AlGrey liked this
Try going into your clover boot options and under graphics enable, uncheck anything regarding Nvidia. This is the only way I can solve this issue, which is also why my web drivers do not work.

Hey, I gived up last time with that setup but now […]

Thank You! This method definitely makes docker us[…]

This post ^ 100% working. Thank you mate, I final[…]

How can i do upgrade from highsierra 10.13.3 to 10[…]

AMD OS X Advertisements