Welcome to AMD OS X

Why not register now to gain full access.

User avatar
by: 49zy
#30490
Hi,
I've installed High Sierra on my desktop PC, the detailed configuration is in my signature. I've been trying to drive Bluetooth on BCM94352Z(Wi-Fi Bluetooth dual module ngff), and it seems there is something wrong with the USB driver.
I tried two different usb drivers, GenericUSBXHCI.kext and FackPCIID.kext with FackPCIID_XHCIMux.kext(I'm using the latest version downloaded from"bitbucket.org/RehabMan/").
    When using GenericUSBXHCI.kext, all usb ports are functioning well but there is no information in USB under System Information. And I'm also suffering from a really slow shutdown(I remember seeing codes like waitting for my keyboard and mouse but timed out). I used CoreMediaIO.framework and SPUSBReporter.spreporter and finally there are information in USB under System Information now.
      ​​When using FackPCIID and FackPCIID_XHCIMux.kext, several USB ports are not aviable(I can still charge my phone using these ports, but the PC can't recognize it), but in USB under System Information there are information about the USB Tree, but only one. I did a little more, using AIDA64 in Windows 10 try to identify the ports. In AIDA64 there are two USB Controller, one is USB 3.1 and another USB 3.0. And the problem is with the USB 3.1 one cause every ports under that USB Bus is not working(my Bluetooth is on USB3.1 BUS port 10, that's how I know my problem is with the USB).

      I'm now using GenericUSBXHCI.kext and I can see the Bluetooth device in the USB tree, but I still can't get it working after trying many different methods...so I think maybe the problem is still with USB. Any idea what to do?
      GenericUSBXHCI with USB info.png
      FackPCIID.kext and FackPCIID_XHCIMux.kext with USB info.png
      2.AIDA64.png
      You do not have the required permissions to view the files attached to this post.

       Advertising

      User avatar
      by: AlGrey
      #30491
      GenericUSBXHCI.kext breaks USB bluetooth.. try this http://forum.amd-osx.com/viewtopic.php?f=24&t=2717
      User avatar
      by: AlGrey
      #30541
      Keep GenericUSBXHCI.kext only + apply bluetooth fix
      User avatar
      by: 49zy
      #30591
      AlGrey wrote:
      Thu Oct 26, 2017 4:37 pm
      Keep GenericUSBXHCI.kext only + apply bluetooth fix
      It's not working...I tried to set CsrActiveConfig to 0x3, but I can't boot into the system. I set it to 0x67 to disable SIP.
      I've installed the kexts from the fix to SLE and here are the kexts I'm using in clover/kexts/other. I've tried USBInjectall.kext, but not working either...What should I do then?
      Screen Shot 2017-10-27 at 6.51.40 PM.png
      Screen Shot 2017-10-27 at 6.50.03 PM.png
      Screen Shot 2017-10-27 at 6.49.25 PM.png
      You do not have the required permissions to view the files attached to this post.
      User avatar
      by: satelli
      #30710
      If you want to utilize the official USB driver, buy a separate USB PCIe Add-on card. Check out my thread here. https://forum.amd-osx.com/viewtopic.php?f=35&t=2906

      淘宝有卖,不到 100。
      User avatar
      by: whxiaolei
      #33110
      49zy wrote:
      AlGrey wrote:
      Thu Oct 26, 2017 4:37 pm
      Keep GenericUSBXHCI.kext only + apply bluetooth fix

      It's not working...I tried to set CsrActiveConfig to 0x3, but I can't boot into the system. I set it to 0x67 to disable SIP.
      I've installed the kexts from the fix to SLE and here are the kexts I'm using in clover/kexts/other. I've tried USBInjectall.kext, but not working either...What should I do then?
      Screen Shot 2017-10-27 at 6.51.40 PM.png
      Screen Shot 2017-10-27 at 6.50.03 PM.png
      Screen Shot 2017-10-27 at 6.49.25 PM.png
      我和你情况类似~我按照AlGrey提供的蓝牙驱动成功驱动了,但是方法不一样。首先我没有改clover的引导配置文件,我只是把S/L/E里的AppleBluetoothMultitouch.kext、AppleMultitouchDriver.kext、IOBluetoothFamily.kext、IOBluetoothHIDDriver.kext删除,然后刷新缓存。最后把AlGrey提供的4个蓝牙驱动文件复制粘贴到EFI/clover/kexts/10.13里面,重启后就有蓝牙了。你可以试试~
      User avatar
      by: emfou
      #38839
      Hello frien, i leave you a message because i have exactly the same problem and i did not found any solutions too
      All usb devices working well, but no usb infiormations in system panel and bluetooth dongle not recognized too.

      Did you finally found a solution?
      Regards
      User avatar
      by: leog
      #40310
      Hey Guys having the same problem all usb work, but no information, and my bluetooth dongle not recognised.
      User avatar
      by: Norton287
      #40313
      For USB reporting in System Profiler copy this file:
      Code: Select all
      https://drive.google.com/drive/folders/1OTbFlEM9E_UubT3Lev98FcAPjFZWFX24?usp=sharing
      to /System/Library/SystemProfiler/ overwriting the one already there.

      yes supported,,anyway got working snow leopard,yos[…]

      Compatibility Check

      Hi Guys, just starting out with the whole Hackinto[…]

      tried but didint worked Post Merged here is my[…]

      Happy Holidays

      Merry Christmas and happy new year Shanee and tha[…]

      AMD OS X Advertisements