Welcome to AMD OS X

Why not register now to gain full access.

#40779
System:
MB: Gigabyte Aorus Ultra Gaming x470
CPU: Ryzen 2700x
Mem: 8GB 3200 Corsair LPX
Video: XFX GTR-S RX580 OC
Dual Monitors
Drive: OCZ 128GB SSD

Okay just leaving feedback over my one day experience. I just rebuilt from my old AM3+ system and windows killed my V1 EFI on the MAC SSD. If you ever reinstall windows, do the same as you would do a Hackintosh, remove all unnecessary drives.
I used Norton287 (Thank you Norton) unofficial version 3 (after hitting walls multiple time with the officials).
viewtopic.php?f=24&t=4127

So after the fact, here is what I know. Follow the tutorial to the T. CSM needs to initially enable in the bios. After installation and you get EFI Clover installed on you drive, you can disable it.
RX580 is supported out of box for High Sierra, so during Post Installation right before the first boot, all you need to do if you get a black screen during the first boot from the internal drive is remove -radoff from the additional ARG from the Clover boot options. I figured this out by accident (uh... let me see what happens if I remove this.) Before I was tried RadDeInit and Injecting ATI. Not needed with this setup. Really simple to remove -radoff.

Next, once you get to the desktop, double click HighSierraAMD USB key and go to clover folder to install the pkg first (aka follow the clover installation tutorial based on your needs). Then use clover configurator to mount the EFI partition from the USB key and the internal hard drive. Once you can browse to both, copy the clover and boot folder from the USB EFI to the hard drive EFI. I usually rename the hard drive folders to 'backup' before copying over the USB folders. I did this because I knew they worked.

Last, use clover configurator to get the latest update and upon re-installation of the latest and greatest, it will only update what's already there. Afterward you can problably turn off CSM and you shouldn't have any issues booting from your internal hard drive.

Voila! A working AMD-OSX on a X470 system.

I apologize if this is confusing, but I am just leaving a record to help someone if need be. :clap: :yawn:

 Advertising

Can't install on Ryzen 2200g

any news on igpu support after apple introduced ve[…]

Yes, I’m not sure what I did but when I trie[…]

monitor no signal

help me why time is finished booth in chameleon, […]

Try OS X yosemite or maverick.. Sent from my SM-[…]

AMD OS X Advertisements