Welcome to AMD OS X

Why not register now to gain full access.

#39457
Hello, I got my hackentosh all the way to the desktop. However I'm having issues creating the boot loader. I installed clover, in fact I've tried 3 different versions of it, and still there is no EFI partition on my drive to boot from. I downloaded clover confgurator and tried to find and copy the boot loader from the AMDHS drive, still no luck. I really need help in creating the bootable partition, and I can't seem to find any other information than, install clover and configure it with cover configurator.

 Advertising

#39459
The EFI partition is already there. Clover just installs to it. When you install Clover select the customise option and tick install to the ESP.
#39479
After reading around the forum I believe my issue is that my drive was partitioned by transmac as an apple partition scheme instead of using disk utility to make it GUID, which is causing the EFI partition to become part of the root file structure instead of it's own boot enabled partiton. This was because the disk utility kept failing to format the drive properly. I've managed to correct this issue by using windows diskpart to clean the drive and change it's partition scheme to GPT, then erasing the drive with disk utility prior to MacOS install. I am however still having one issue, MacOS is failing to install on the drive when it has a GUID partition scheme. The installer log shows the installation process reaches the point of beginning the extraction, but never actually extracts. Leaving the installer to run for several hours does not help, both drive indicator lights show no transfer of data, and yes I did keep the mouse moving to stop the installer from going to sleep. When I installed to an apple partition scheme the installation did actually occur within 15 min. I have no idea how to fix this and would greatly appreciate help in resolving this issue.
#39485
Have you tried formatting the drive with Disk Utility inside the installer?
#39488
Yes, in fact that appears to be the bulk of my issues. The drive will always fail to format and remount in disk utility when trying to format to a GUID partition scheme, until I took the drive and gave it a GPT format in diskpart then used the built in disk utility to erase and reformat. What's most puzzling is how quickly the installer works when the drive is an Apple partition scheme and how it fails to even begin extracting data when it's GUID. I've read a few other threads where other people had to wait a few hours and it suddenly kicked off and did the installation at some point within 2-5 hours, but surely this can't be what's supposed to happen.
Post Merged
Just to be clear, I formatted the drive in diskpart to GPT, then switched to the OSX installer and used the erase on disk utility to make a new partition with a GUID scheme, and it was a journaled partition.

I did a trick so that i can dual boot Hackintosh a[…]

Ryzen 2700x - Success

If you want to increase just overclock it! Now min[…]

Small problems after install

As a result of the hard work, I managed to install[…]

I want to buy Acer Nitro 5 AN515-42-R8DY with Ryze[…]

AMD OS X Advertisements