Welcome to AMD OS X

Why not register now to gain full access.

General chat and support for running on a Virtual Machine.
User avatar
by: nJSpS
#52695
Artem Ryder wrote:Image

Same things here. Can somebody help us please?
I've been using this tutorial step by step
bruh gaming wrote:when I try launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist it says no such file or directory
I'm having exaktly the same problems after following the guide. Any ideas?

 Advertising

#53478
Artem Ryder wrote:Image

Same things here. Can somebody help us please?
I've been using this tutorial step by step
maRci002 wrote:
Artem Ryder wrote: Mon May 20, 2019 8:07 pm Image

Same things here. Can somebody help us please?
I've been using this tutorial step by step
I have same problem, Artem Ryder were you able to resolve that with "temporery User Account to skip the Setup" guide?
I deleted all files and I don't want to redownload the whole thing if it doesn't help.

ps: about a month ago I was able to finish installation and it worked but now I ran this problem. (maybe because on Windows I enabled hyper-v and VMware hated it so I just disabled it with a flag https://stackoverflow.com/a/41968105/4609658)
Anyway when I downloaded the VM the installation always said "this copy of the install macos mojave application is damaged" (I downloaded it three times from here https://kb.amd-osx.com/guides/vmware/prerequisites.html and It had always another hash so maybe they were all corrupted, but in therminal I just set date back like 2018 "date 110110202018" and I was able to install it but I was never able to finish after installation process due to this issue)
I just finished setup my vmware osx. Here how I do it.

My vmware setup

Processor
- Number of Processor 1
- Number of cores per processor 4
- Enabled / Tick Virtualize Intel VT-x/EPT or AMD-V/RVI
RAM - 16GB
HDD - 120 GB
Display
-1 Monitor
- Maximum Resolution

After you follow all guide until Installing macOS you will face this problem.

1. VMware Workstation Device/Credential Guard are not compatible <-- Turn off Hyper-V from Windows Features.
2. On Install MacOS, you will face this problem "application is damaged, can’t be used to install macOS". Fix as below.
- Turn off internet from your computer / unplug cable
- Open terminal
- Run this command date 102523382016
- Close terminal
- After that try to install without internet <-- For not auto-detect date
- Wait until finish.

3. After done installation, you will get one more problem which is said "The CPU has been disabled..." The solution is here.
- Close your vmware
- Open your Mojave VMX files <-- https://kb.amd-osx.com/guides/vmware/ma ... chine.html at the end of the line. Choose your cpu version. I'm using FX CPU.
- Find virtualHW.Version = "xx" and change to virtualHW.Version = "10" <-- You can change to your version after done installation.
- Find smc.version = 0 <-- delete this if you got one.
- Paste this code at the end
Code: Select all
cpuid.0.eax = “0000:0000:0000:0000:0000:0000:0000:1011”
cpuid.0.ebx = “0111:0101:0110:1110:0110:0101:0100:0111”
cpuid.0.ecx = “0110:1100:0110:0101:0111:0100:0110:1110”
cpuid.0.edx = “0100:1001:0110:0101:0110:1110:0110:1001”
cpuid.1.eax = “0000:0000:0000:0001:0000:0110:0111:0001”
cpuid.1.ebx = “0000:0010:0000:0001:0000:1000:0000:0000”
cpuid.1.ecx = “1000:0010:1001:1000:0010:0010:0000:0011”
cpuid.1.edx = “0000:1111:1010:1011:1111:1011:1111:1111”
featureCompat.enable = “FALSE”
- And save the files

4. Run your vmware and you will see the apple icon on boot. If it appear "xx minutes remaining .... ", means it work. If not, you need to follow the guide from the start again. Delete your vmware machine and configuration files. Start with fresh installation.
5. If it work, don't forget to enable USB 2.0 on your configuration. <-- To enable Keyboard and Mouse

My Rig for reference only.

- FX8350
- Asrock 980DE3-U3S3 2.0
- 32GB 1600mhz Dual Channel
- 2TB Sata
Installer doesn't detect M.2 SSD

I can boot to the installer without problems, howe[…]

Of course, if all the PCIe slots are full or ina[…]

Hi all, sorry for my english ^^" I'm try to i[…]

Hi, I have same MB with 2700 CPU and RX 580 runni[…]