Welcome to AMD OS X

Why not register now to gain full access.

General chat and support for running on a Virtual Machine.
User avatar
by: Slats
#48088
Hello,

I can't get past the Data & Privacy Section, it keeps rebooting or it shows a black screen with the rebooting sign! I'm using the knowledge base guide, but it doesn't get past the setup of Mojave. I'm using VMware Workstation 15 Pro, did all the steps correctly. So I need some help with getting past the setup bit.

Thanks

 Advertising

#50595
Hello, I know a Solution, but Shanee had removed a Giude/Tuturial, which explains howto create a temporery User Account to skip the Setup.

the Links was: viewtopic.php?f=59&t=6029

Everytime a call this Link, I get the message, even when I'm logged in the Forum: You are not authorised to read this forum.

I believe that there is no other Solution.

Greetings from Germany, Olaf
#50600
Olaf Neumann wrote:Hello, I know a Solution, but Shanee had removed a Giude/Tuturial, which explains howto create a temporery User Account to skip the Setup.

the Links was: viewtopic.php?f=59&t=6029

Everytime a call this Link, I get the message, even when I'm logged in the Forum: You are not authorised to read this forum.

I believe that there is no other Solution.

Greetings from Germany, Olaf
XLNC wrote:
Code: Select all
/sbin/fsck -fy
/sbin/mount -uw /
Then create this file to skip the apple setup screen:
Code: Select all
touch /var/db/.AppleSetupDone
Now create a temporary user account "Temp User" with password "password" and home directory "temp"
Code: Select all
launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist

dscl . -create /Users/temp
dscl . -create /Users/temp UserShell /bin/bash
dscl . -create /Users/temp RealName "Temp User" 
dscl . -create /Users/temp UniqueID "510"
dscl . -create /Users/temp PrimaryGroupID 20
dscl . -create /Users/temp NFSHomeDirectory /Users/temp
dscl . -passwd /Users/temp password
dscl . -append /Groups/admin GroupMembership temp
dseditgroup -o edit -a temp -t user admin
Now reboot :
Code: Select all
shutdown -r +0
So macos will now directly take you to the login screen . where it will ask you to enter password .
type password and hit enter to login.
you will reach Data & Privacy screen again so click next to proceed ( don't worry, it wont reboot now ) and so after few clicks you will reach Desktop .

Now go to System Preferences -> User & Groups and create a Administrator account of your choice with your real User name
After that logout from this Temp User account and login into your own admin account
Finally delete this Temp User account by going into System Preferences -> User & Groups.
#50607
Hello Shaneee,

I have a Question in General to solve the setup Problem in VM or with real Hackintosh on PC.

I have a hackintosh with a SSD and HDD.
My HighSierra is installed on the HDD.

Now I installed Mojave 10.14.6 (Vanilla Install) on the SSD.
Here I have the same Problem, I can't pass the Setup as in the
VMware.

When I use the Terminal in High Sierra, I can't use the commands
directly.

The command "dscl" only works with sudo in Terminaland only for HighSierra.

When I try something like this in the Terminal, I get a Error.
Code: Select all
dscl . create /Volumes/SSD/Users/Temp
When I boot from a pendrive wit USB-Installer in singleMode,
the Terminal gives my the Error: no such command?

Regards, Olaf
#52197
Artem Ryder wrote: Mon May 20, 2019 8:07 pm Image

Same things here. Can somebody help us please?
I've been using this tutorial step by step
I have same problem, Artem Ryder were you able to resolve that with "temporery User Account to skip the Setup" guide?
I deleted all files and I don't want to redownload the whole thing if it doesn't help.

ps: about a month ago I was able to finish installation and it worked but now I ran this problem. (maybe because on Windows I enabled hyper-v and VMware hated it so I just disabled it with a flag https://stackoverflow.com/a/41968105/4609658)
Anyway when I downloaded the VM the installation always said "this copy of the install macos mojave application is damaged" (I downloaded it three times from here https://kb.amd-osx.com/guides/vmware/prerequisites.html and It had always another hash so maybe they were all corrupted, but in therminal I just set date back like 2018 "date 110110202018" and I was able to install it but I was never able to finish after installation process due to this issue)

Hi there! What about InDesign? Is there any versio[…]

Install 10.15.1 using clover with latest vanilla i[…]

I hope you don't mind me replying in English, sinc[…]

Good afternoon, I'm new here and i got here becau[…]