Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#53427
Image
Build
Motherboard: Gigabyte X570 Aorus Elite
CPU: AMD Ryzen 7 3700X
CPU Cooler: bequiet! Dark Rock 4
GPU: Sapphire Radeon RX 5700 8 GB
Memory: HyperX Black Fury 16 GB (2 x 8 GB) DDR4-2666
Storage: Samsung 970 EVO Plus 500GB NVME
Bluetooth: Asus BT400 usb dongle
Wifi: None
Case: NZXT H500
Power Supply: Cougar CMX700
Monitor: LG 27UL500

MacOS: 10.15.3 beta
OpenCore: 0.5.4
BIOS: F11

Benchmarks
Spoiler:
Image
Image
Image
Bios Settings:
- Load Optimized Defaults
- XMP profile
- CSM disabled

OpenCore
Spoiler:
ACPI
- SSDT-PLUG.aml (fix CPU PM)
- SSDT-XOSI.aml (fix CPU PM)
- SSDT-SBRG.aml (fix EC)
- SSDT-NVME.aml (show SSD as internal)
- SSDT-USBX.aml (fix USB power)
- SSDT-XHC2.aml (rename XHC0 controller)
- Acpi patch for rename _OSI to XOSI

Kexts
- Lilu.kext
- WhateverGreen.kext
- VirtualSMC.kext
- AppleALC.kext (Sound ALC1200 layout 2)
- SmallTreeIntel82576.kext (Intel ethernet)
- AGPMInjector.kext (Proper video injection. Depends on video and smbios)
- AMD-USB-Map.kext (Mapping Usb ports)
- Kernel patch for proper CPU PM

SMBIOS
iMac 19,1 most stable

Drivers
- ApfsDriverLoader.efi
- HFSPlus.efi
- FwRuntimeServices.efi


Update:
- Proper USB ports mapping
- Updated to last versions of OC & kexts files
- SMBIOS changed to iMac19,1 for stability
- Updated SSDTs

Everything works except sleep. If you want to use attached EFI folder you need to generate your own SMBIOS SN.
You do not have the required permissions to view the files attached to this post.
Last edited by anti on Tue Jan 14, 2020 11:41 am, edited 6 times in total.
c4orbi, Fryinfarmer, iGPU and 1 others liked this

 Advertising

#53464
Hi Anti,

First I want to say INFINITELY thank you for posting your EFI. I finally managed to get the system installed after being stuck for more than a week.

My system is 2700X / X570i Aorus Pro Wifi / MSI 5700 XT

Everything is working except the BT/WIFI card. My MB (Aorus x570i pro wifi) had one on board that I swapped with another confirmed supported (Broadcom BCM94352Z DW1560 6XRYC).

Could you tell me if in your EFI you added any setting/kext to disable the onboard card?

Do you have any suggestions about what could be preventing it to work properly?
#53473
enra enra wrote:Shutdown works but I had an issue also experienced by other users on this forum with the system freezing and rebooting after 5 or more minutes of inactivity.

Seems like changing the SMBIOS model to "iMac9,1" fixes it and in some cases also enable sleep/wake.
You mean iMac19,1? Yeah I'm on it, no sleep and the shutdown still doesn't work. (I have tried removing all the USB devices as well)
About the 5/10 min idle reboot, I've "fixed" with amphetamine.
enra enra liked this
Installer doesn't detect M.2 SSD

I can boot to the installer without problems, howe[…]

Of course, if all the PCIe slots are full or ina[…]

Hi all, sorry for my english ^^" I'm try to i[…]

Hi, I have same MB with 2700 CPU and RX 580 runni[…]