Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.

Managed to get a successful install this week after some hassle with OC and the installer. Visual artifacts everywhere and all. However I had a 10.14.5 installation I upgraded to 10.15.1. That installation had Clover (boooo) on it so I went and deleted that **** and put OC EFI folder on the partition once upgrade was done. Everything EXCEPT sleep works.

My previous 10.14.5 success post is here for ref: viewtopic.php?t=8899

I followed exclusively official OC docs: https://khronokernel-2.gitbook.io/openc ... top-guide/

And of course I used our official AMD OS X guide for more info: https://vanilla.amd-osx.com

I did get stuck on the .dsl/.aml file part of the OC docs and that's because the docs aren't that clear there. Basically, .dsl files are source code and you want COMPILED source code so that would be .aml files. Just read that section slowly and take your time with the docs. They're not hard, actually most of the info should be irrelevant to you, they're just dense with info and you might lose track.

* Followed the OC docs with ONE crucial exception: Disabled above 4g decoding/memory. I could not boot with it enabled for some reason.


What works
* Native Audio
* Bluetooth
* Wifi
* AirDrop
* Handoff
* USB 2.0 and USB 3.1
* Ethernet
* NVMe (both slots)
* Mic (Blue Snowball)
* Headphones (front and back panel)
* 1x HDMI and 1x DP monitors

What does not work
* Dynamic wallpapers (they have weird red stripes)
* Sleep (sleep is weird. my peripherals go out when I click "Sleep" button on Apple icon but CPU, GPU and fans are on. I tried replugging the keyboard and mouse and they just didn't light up. I had this one case where the computer went to sleep on its own and it woke up fine on mouse click. I might've literally dreamed this bc I was tired. I will do more testing with this and update the post.)

* Lilu
* NullCPUPowerManagement
* SmallTreeIntel82576
* VirtualSMC
* SMCProcessor (not required, might not actually do anything)
* SMCSuperIO (not required, might not actually do anything either)
* AppleALC, layout 7
* WhateverGreen (crucial, DP aka my other monitor does not work without it. I know some don't need this anymore since Navi native support)

Other fixes
* For some reason I did not need to apply the USB fix this time: https://amd-osx.com/forum/viewtopic.php?t=4986

* ApfsDriverLoader.efi
* FwRuntimeServices.efi
* HFSPlus.efi
* UsbKbDxe.efi
* VBoxHfs.efi
* VirtualSmc.efi

My benchmarks:




No Whatevergreen (these are just for testing. only the HDMI monitor worked):




Geekbench 4 (old):

Last edited by arn0 on Sat Nov 16, 2019 4:27 am, edited 1 time in total.
amdpush, sparaker liked this


I have completed an install with a 5700 and a 3600 with B450-I Asus.... mine is working well with 10.15.1 with clover sleep isn’t working everything else is fine.... if I upgrade to 10.15.2 Beta 2 clover won’t boot but if I use OC it boots without issue sleep issue is still present. I know some have been able to make sleep work with 10.15.2 Beta 2 not sure what I may be doing wrong.... also I am wondering why I can’t get Clover to boot 10.15.2 Beta 2
I was wondering if you use an M2 NVME SSD on your X570? If so, is it a PCI-E 4.0 drive like the Corsair MP600?

Im interested in finding out whether the X570 boards PCI-E 4.0 is seeing the SSD performance benefits on MacOS, have you run any read/write benchmarks?
Thank you for the detailed post, it is proving to be very helpful to me.

I have this same setup (except a 3800X) and I am stuck at the aml/dsl section. Which ones did you use? Did you simply compile them with MaciASL?
Ryzen 5 2400g sound cracking

I have Catalina 10.15.1 with opencore, AppleALC la[…]

Newbie install problem

Thank you. Now at least something happens. A conso[…]

So lately i just changed my motherboard to MSI b45[…]

you should upgrade your wifi to 5ghz, 2.4ghz will […]