Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#52263
Catalina 10.15.1 Installed with Algrey Patches (Massive Thanks) :thumbup: :thumbup:
Ryzen 3700X Processor
MSI MPG X570 Gaming Plus
Vega 64 GPU
1TB Samsung Evo Nvme
Screenshot 2019-11-07 at 04.56.52.png
BIOS Settings
Above 4G Decoding Enabled
CSM Disabled
XCHI On


Installer Vanilla based USB with OpenCore 0.5.3 Bootloader, Patches Added.
No Boot Args Required

Working:
Sound set to Layout ID 7
Graphics with latest Whatevergreen Kext, All Ports
DRM is Working, Netflix in Safari and Apple TV+
iMessage
iCloud

Not Working
Nothing to List (Everything is great)

EFI Uploaded to test and Observe :thumbup:
Post Merged
I can Also Confirm All Varients of MPG from MSI are Woking fine, USB2.0 Support Also Working
Post Merged
Newer EFI
You do not have the required permissions to view the files attached to this post.
Shaneee, gopal334, jasonhu and 2 others liked this

 Advertising

#52336
Congrats. Might get the MSI MPG X570 Gaming Plus as my upgrade then as it seems pretty compatible.
#52699
How do you install Open Core, I have no idea where to even get started.

I have a MSI X570, unable to get the LAN drivers working; so hitting a brick wall on the Installer at `can't contact recovery server`.
Post Merged
t3stm1k3 wrote: Sun Dec 01, 2019 8:12 pm How do you install Open Core, I have no idea where to even get started.

I have a MSI X570, unable to get the LAN drivers working; so hitting a brick wall on the Installer at `can't contact recovery server`.
I finally got my MSI x570 LAN working with clover. Got some help from amd-osx's discord.
#53066
I got error just boot only half way.

00:000 00:000 OC: Setting NVRAM 7C436110-AB2A-4BBB-A880-FE41995C9F82:nvda_drv - Not Found
00:034 00:034 OC: Setting NVRAM 7C436110-AB2A-4BBB-A880-FE41995C9F82:prev-lang:kbd - Not Found
10:391 10:357 OC: Kernel patcher result 3 for kernel (algrey - cpuid_set_cache_info - cpuid 0x8000001D instead 0) - Not Found
10:628 00:236 OC: Kernel patcher result 7 for kernel (algrey - - skip cpuid_cores_per_package test) - Not Found
10:898 00:269 OC: Kernel patcher result 29 for kernel (algrey - lapic_init - remove version check and panic) - Not Found
10:929 00:031 OC: Kernel patcher result 31 for kernel (algrey - lapic_interrupt - skip checks and prevent panic) - Not Found

My build
AMD Ryzen 9 3900X
MSI MPG X570 Gaming Edge WiFi Motherboard
XFX RX 5700 Xt Thicc III Ultra 8GB
fenvi T919 for macOS PC PCI WiFi Card
Samsung 970 EVO Plus SSD 1TB - M.2 NVMe

Could you please share your EFI? I want to put in another hackintosh drive to test this build.
#53076
Thanks very much for sharing the EFI. I have a same MOBO with 5700 XT and different CPU. I will give it a try in a few
Post Merged
I was able to boot and create the partition, but for some reason, the ethernet is not working, so I can't install the OS. I checked that your EFI already has the RealTek Kext.. Not sure what I am off here..
#53118
tosehee wrote: Tue Dec 17, 2019 4:54 am Thanks very much for sharing the EFI. I have a same MOBO with 5700 XT and different CPU. I will give it a try in a few
Post Merged
I was able to boot and create the partition, but for some reason, the ethernet is not working, so I can't install the OS. I checked that your EFI already has the RealTek Kext.. Not sure what I am off here..
I'm having the same issue. Have you fixed your issue?

You should not need the DSDT.aml nor the SSDT-EC.d[…]

Matx board? Sleep and wake is fine?)

Speak to XLNC on the Discord. It's a non Zen issue[…]

Help booting Mojave installer

OpenCore supports all version of 10.13, 10.14 and[…]