Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
#51396
about.png
# Specs
CPU: Ryzen 7 3700X
MOBA: Gigabyte X570 Aorus Pro (non-WIFI)
GPU: Gigabyte Radeon Vega 56 Gaming OC - 8GB
RAM: 16GB (2x8) HyperX Predator (non-RGB)
SSD: XPG GAMMIX S11 PRO 256GB
... and lot's of HD's

# Not working:
- IOMMU
- Android studio (simulator)
- BitTorrent\uTorrent (instead, i'm using transmission)
- My generic wi-fi dongle (didn't tryied much)
- iMessage (Didn't bothered much)
- (MAYBE) Airdrop (can't test it right now)

# Working nice:
- Everything (including Xcode, Xcode simulator, iCloud, Photoshop (After AMD-OSX Patches), audio, ethernet, ...)
- All USB Ports (including USB-C!)
- Virtualization on VirtualBox (couldn't make VMWare work on it)

---

# Kexts:
- AppleALC.kext
- Lilu.kext
- NullCPUPowerManagement.kext
- SmallTree-Intel-211-AT-PCIe-GBE.kext
- SmallTreeIntel82576.kext
- VirtualSMC.kext
- WhateverGreen.kext

# Drivers:
- ApfsDriverLoader.efi
- AppleImageCodec.efi
- AppleKeyAggregator.efi
- AppleKeyFeeder.efi
- AppleUITheme.efi
- AptioInputFix.efi
- AptioMemoryFix.efi
- AudioDxe.efi
- DataHubDxe.efi
- FSInject.efi
- FirmwareVolume.efi
- NvmExpressDxe.efi
- PartitionDxe.efi
- Ps2MouseDxe.efi
- SMCHelper.efi
- UsbKbDxe.efi
- UsbMouseDxe.efi
- VBoxExt4.efi
- VBoxHfs.efi

---

# Overall thoughts:
I'm pretty happy with the overall result, the computer is a beast, my first hackintosh build.
I work with iOS/Android development, and i couldn't be happier. Took me about 2 nights to find the right combo of
kexts and drivers (i didn't knew much) and after "finishing" it, it's working flawlessly.
computer2.jpg
You do not have the required permissions to view the files attached to this post.
MylNes liked this

 Advertising

#51398
Hi
felipecramos wrote:
about.png
# Specs
CPU: Ryzen 7 3700X
MOBA: Gigabyte X570 Aorus Pro (non-WIFI)
GPU: Gigabyte Radeon Vega 56 Gaming OC - 8GB
RAM: 16GB (2x8) HyperX Predator (non-RGB)
SSD: XPG GAMMIX S11 PRO 256GB
... and lot's of HD's

# Not working:
- IOMMU
- Android studio (simulator)
- BitTorrent\uTorrent (instead, i'm using transmission)
- My generic wi-fi dongle (didn't tryied much)
- iMessage (Didn't bothered much)
- (MAYBE) Airdrop (can't test it right now)

# Working nice:
- Everything (including Xcode, Xcode simulator, iCloud, Photoshop (After AMD-OSX Patches), audio, ethernet, ...)
- All USB Ports (including USB-C!)
- Virtualization on VirtualBox (couldn't make VMWare work on it)

---

# Kexts:
- AppleALC.kext
- Lilu.kext
- NullCPUPowerManagement.kext
- SmallTree-Intel-211-AT-PCIe-GBE.kext
- SmallTreeIntel82576.kext
- VirtualSMC.kext
- WhateverGreen.kext

# Drivers:
- ApfsDriverLoader.efi
- AppleImageCodec.efi
- AppleKeyAggregator.efi
- AppleKeyFeeder.efi
- AppleUITheme.efi
- AptioInputFix.efi
- AptioMemoryFix.efi
- AudioDxe.efi
- DataHubDxe.efi
- FSInject.efi
- FirmwareVolume.efi
- NvmExpressDxe.efi
- PartitionDxe.efi
- Ps2MouseDxe.efi
- SMCHelper.efi
- UsbKbDxe.efi
- UsbMouseDxe.efi
- VBoxExt4.efi
- VBoxHfs.efi

---

# Overall thoughts:
I'm pretty happy with the overall result, the computer is a beast, my first hackintosh build.
I work with iOS/Android development, and I couldn't be happier. Took me about 2 nights to find the right combo of
kexts and drivers (i didn't knew much) and after "finishing" it, it's working flawlessly.
computer2.jpg
Hi, good job!

I have pretty much the same configuration but the fans of my GPU don't run. How do you manage to make them running?

My USB 2.0 stopped working several weeks ago out of the blue... I still don't know why, I didn't change a thing 😂

Please, let me know if you have some insights to help me resolve my issues.

Thank you :)
#51405
MylNes wrote:
Hi, good job!

I have pretty much the same configuration but the fans of my GPU don't run. How do you manage to make them running?

My USB 2.0 stopped working several weeks ago out of the blue... I still don't know why, I didn't change a thing 😂

Please, let me know if you have some insights to help me resolve my issues.

Thank you :)
Hello, my GPU fans work normally! With the kexts / drivers that i've used, all worked out of the box!
And as i've said, all of my USB's (including USB-C) worked out of the box too.
What are the differences between our configurations?

Proof: Geekbench score (Dunno if it's good or bad, have zero reference for this)
You do not have the required permissions to view the files attached to this post.
#51427
Thank you for your answer.

Except for our CPUs and MOBO, nothing is really different between our configurations. I don't think that SSDs change a thing.

I think that I will reinstall the all thing with your kext and drivers. Which tutorial did you follow?
You do not have the required permissions to view the files attached to this post.
#51438
MylNes wrote:Thank you for your answer.

Except for our CPUs and MOBO, nothing is really different between our configurations. I don't think that SSDs change a thing.

I think that I will reinstall the all thing with your kext and drivers. Which tutorial did you follow?
I didn't followed any tutorial in specific, i've watched a lot of tutorials at random on internet, and then found the amd-osx site and got the config.plist and kexts from this post
#51441
felipecramos wrote:
Mon Oct 07, 2019 11:06 am
MylNes wrote:Thank you for your answer.

Except for our CPUs and MOBO, nothing is really different between our configurations. I don't think that SSDs change a thing.

I think that I will reinstall the all thing with your kext and drivers. Which tutorial did you follow?
I didn't followed any tutorial in specific, i've watched a lot of tutorials at random on internet, and then found the amd-osx site and got the config.plist and kexts from this post
Thanks for the heads up! :thumbup:
#51511
MylNes wrote:Sorry awesometic I can't answer you on the topic, I never tried VirtualBox on my hackintosh.
Hi MylNes, thanks for your answer.

I have investigated in the last few days and figured out that that slow performance seems normal since Ryzentosh doesn't support IOMMU and AMD-V, KVM.
This means it doesn't support H/W accelerated virtualization on VirtualBox. And it is undoubtable because macOS is designed for Intel CPU.

I still have several wonders (for example, why it is not that bad on Xcode virtualization), but I just accepted that there's no option to me. :)
MylNes liked this

You'll get it recognised with full resolution bu[…]

Hi, i'm Julien from France and i'm a newcomer on r[…]

Got to the install screen where disk utility and i[…]

Hey, looking forward to seeing this link to the mo[…]