Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.
User avatar
by: arstonemac
CPU: Ryzen 5 1400
MOBO: ASUS Prime B350-Plus
SSD: Crucial m550 128gb
GPU: NVIDIA GeForce 760 2GB

So, after 3 days of battle, I have come out successful! Mojave is running happily and stable on my system!

Install Process:
open Mojave.app (right click -> contents)
format usb as apfs
restore baseSystem.dmg from Contents/SharedSupport to usb
copy SharedSupport folder from Mojave.app/Contents to "OS X Base System"/Mojave.app/contents
create prelinkedkernels and kernels folders in S/L/
copy prelinkedkernel.amd to "OS X Base System"/S/L/prelinkedkernels/
rename original prelinkedkernel.amd to just prelinkedkernel
copy prelinkedkernel to "OS X Base System"/S/L/prelinkedkernels/ (replace)
use clover or "diskutil mountDisk diskXsX"to mount efi of USB
delete everything in there
copy everything from Norton's EFI folder to USB EFI folder

from there follow guide to the letter and poof, you're on mojave desktop!

Fixing Atheros wifi:
Find IO80211Family.kext from High Sierra
Find IONetworkingFamily from High Sierra
Copy these 2 kexts to S/L/E
Use Kextwizard to repair permissions and rebuild kextcache

Update: Realtek ALC887 audio fixed. Installed latest AppleALC and Lilu, set layout to 50, rebooted and sound works!!!
Update: Tried signing into App Store, it asked for my account pw and then nothing. Won't let me sign in and doesn't say I'm signed in
Update: Tried signing into iCloud, it only checked Photos and it's freezing the System Prefs app
You do not have the required permissions to view the files attached to this post.


User avatar
by: webdesz
Does sleep work for you?

My Mojave 10.14.3 install (Ryzen 7, B-350, Radeon RX 570) sleeps well but after wakeup it works for 2 seconds and then crashes/freezes.

i'm using this installer but after verbose boot mo[…]

nice. details on the ram ? https://www.microc[…]

Inject this kext, https://files.amd-osx.com/XLNCUS[…]

Hi All, First time long time haha, CPU: R7 1700 […]