Welcome to AMD OS X

Why not register now to gain full access.

If you've got your system running near to perfect then you can share your success story here.

Sleep works, vega fans roar, and sensors suck...but otherwise incredibly fast and stable! (OSX on an M.2 drive is just AWESOME).



Motherboard: ASUS ROG Strix X370-F Gaming 5
CPU: Ryzen 7 1700X
RAM: 32GB Corsair Vengeance
Graphics: ASUS ROG Strix RX Vega 64 OC 8GB
Cooling: Stupid Corsair H110i cooler
Drive: EVO960 M.2 NVMe


I followed guide to Install macOS Mojave on AMD platforms, and when I ran the 10.14.1 installer, it downloaded the 6GB 10.14.4 update and applied the patch. I ended up with a working boot of 10.14.4, with a bunch of issues. After a bunch of messing around, I found AMD Vanilla Clover Patches, and gave it another go, but still had the same issues.

Radeon Vega 64

So the problem is the 2.0.2 version of AMDSupport.kext that is in prelinkedkernel.amd, but AMD10000Controller.kext is expecting version 2.0.8, so it refuses to load. I was hoping the kernel patch would fix this, but it didn't for me.

The solution was to copy AMD* from /System/Library/Extensions out of the BaseSystem.dmg (10.14.1 versions) and replace the ones in mine. That works great! Full acceleration, no issues yet. Only issue I have still is that the fans on the card are either off, or on full blast. The tipping point seems to be 35 degrees, so it roars a lot. VGTab doesn't work, but that's to be expected with these OC version graphics cards...it seems to just disable the fans completely.

USB Ports

Only having 1 working USB port was getting annoying, so I used this tutorial to fetch my DSDT with DPCIManager, patch it with MaciASL, and put it in the right spot. The first patch worked for me. All USB ports working!


I followed this tutorial, and since this motherboard has SupremeFX audio chips (S1220A), I got lucky with the first number (7) in the list. Audio works!


I tried VirtualSMC and FakeSMC, and as you can see above, I have dick for sensors. I have a Windoze boot, so I ran AIDA64, and found out my LPC chip is a ITE IT866SE. Unfortunately, ITEIT87X.kext doesn't work. I saw in a thread somewhere that this chip is unpublished. So out of luck there I guess.

Stupid Corsair H110i cooler

So this thing is entirely USB controlled, and with no drivers or iCUE support in OSX, there is no way for it to scale the pump or fans with cpu temperature. So what I did was connect the rad fans to my motherboard fan headers, then set the pump to "extreme". Then I can control the fans in the bios, and leave the pump cranked. Problem solved!

I found that the pump tries to talk to the computer, however, and will wake it from sleep. I made an adapter cable to a Type-A usb2.0 connector, so i can easily plug/unplug it from outside the case, although I see no need to plug it in anymore, and just leave it unplugged.


I realized that without the USB connection, the cooler will forget its settings, and revert to quiet pump mode. So it needs power through the USB to keep the settings. So what I did was disconnect the data wires on my custom cable, and voila!! The cooler has power, but no data connection to wake up the computer! :clap:


This is with no overclocking set in the bios.


Thanks for reading! Happy hacking!



stucks at Apple logo

@Shaneee , Lilu and Whatevegreen is UPtodate and[…]

You’ll need a GPU to run macOS on that. See […]

[Fixed] RX580 not booting

I will double check the AHCI support as soon as I […]

My configuation: GPU:Sapphire Vega64 Limited Editi[…]