• [Success!] AMD Ryzen 5 1600/ASrock AB350 Pro4/ Radeon R9 280

  • If you've got your system running near to perfect then you can share your success story here.

Please remember to read and follow the rules here.

Please Donate if you've found the website useful. Thanks.

If you've got your system running near to perfect then you can share your success story here.
#32472 by Fenixandthepowermac
Sat Nov 18, 2017 9:04 am
With very special thanks to Norton287, who is from here on out my hackintosh hero, this system worked out of the box. The only thing I have left is the PS2 drivers and TRIM. For Ethernet, use RTL8111.kext, and for sound the included Voodoo audio works fine.

When I try force enabling TRIM, it works, but all of my drives are shown as external. Odd, I even disabled hotplugging in the EFI, didn't fix anything.

This system is very fast. Ryzen seems perfect for MacOS Sierra, and Logic is loving the extra cores! Now I just need to figure out how to store logic instruments on a different hard drive, my SSD is tiny. x3

 Advertising

#37551 by RagingDemon
Sun Feb 11, 2018 2:57 am
Do you mind advising what image you used? Should I bother with HighSierra? I'm new to MacOS so I have no idea. I thought latest and greatest.

#37553 by dragonx41
Sun Feb 11, 2018 3:42 am
RagingDemon wrote:Do you mind advising what image you used? Should I bother with HighSierra? I'm new to MacOS so I have no idea. I thought latest and greatest.
Mate put your specs in your signature or people gonna find it difficult to advise what you should be using.

#37554 by RagingDemon
Sun Feb 11, 2018 3:48 am
Thanks @dragonx41 signature updated :thumbup:

#37557 by dragonx41
Sun Feb 11, 2018 3:58 am
RagingDemon wrote:Thanks @dragonx41 signature updated :thumbup:
I used this one viewtopic.php?f=23&t=2948 and used transmac to restore to USB to create my USB Key . you might have to add some boot arguments to boot with your Nvidia Card.

Also Check out the Videos XLNC done on youtube as well as using the AMD OSX Discord
RagingDemon liked this

#37558 by RagingDemon
Sun Feb 11, 2018 4:32 am
Thanks again Dragon. Looks like I'm about to download another large file.... okay I'll give it a shot and advise if I get stuck.
Post Merged
Ok success!

Using the following image also changed the USB I was using to be sure.

HighSierraAMD_V2 UEFI.dmg

https://www.youtube.com/watch?v=Ti8YRbBXzyw

I've now formatted and installed MacOS on the NVME ssd M.2 Ultra.

Now looking for the post.sh to copy over the "Required files" kexts etc!!

https://www.youtube.com/watch?v=Ti8YRbBXzyw

Thanks Don!
Post Merged
Update: I can into the system from SSD via the USB still. Still need to figure out the following;

1. Boot from SSD without the USB
2. Edit config.plist (I'm new to Mac, be kind. I have Clover Configurator installed)
3. With the above ability. Enable my GTX 1060

Other that the graphical issues it's fast 😁 :crazy:

A steep learning curve
dragonx41 liked this