• Keyboard + mouse working but not other USB devices

  • Help with AMD OS X after installation.

Please remember to read and follow the rules here.

Please Donate if you've found the website useful. Thanks.

Help with AMD OS X after installation.
#19295 by Zlll
Sat May 13, 2017 2:51 am
Hi there,

I started my Hackintosh experiment following Shaneee's tutorial and luckily got my PC booted into the OS X. It's really amazing and satisfying by doing all these from scratch. I have to thank Shaneee and the experience shared by all of you in this forum. You guys rock! :thumbup: !!

Belows are the post installation issues I have encountered so far:

1. To be honest, I am a newbie to all these. I installed the latest Enoch bootloader but it have taken me hours to figure out that you have to put all those fixes in the USB installer into your HDD if you would like to boot thru the HDD as smooth as the installer does.

2. Ethernet: Mine is Atheros AR8131 and I have gotten a kext (AtherosL1cEhernet.kext) from insanelymac that fix it like a charm!
p.s. I have to put it under S/L/E but not E/E to get it works.

3. Graphic card: It's sad to know that RX 460 could only be supported by Sierra which do not fit my CPU, Phenom II, at the moment. I have dug into the possibility of using the HD4250 internal graphic of my mobo for graphic acceleration and in vain.

4. After using the Spakk's usbfix v4, my usb keyboard and wireless mouse worked with no problems. However, I discovered that USB flash drives could not be detected when booted into the OS. They have been recognized under the disk utilities of the USB installer but not showing up when I logged on into the OS. I have tried switching the port and in no avail. Plugging other devices like USB optical drive did not work neither.

5. Audio works fine with latest VoodooHDA.Kext whilst the mic is port is not working.

Any help would be appreciated :clap: Thanks once again for this nice forum!

Updated as of 16.5.2017
Swabbed Spak's USB Fix with Shane's. Other usb devices (optical drive, flash drives etc.) can now be recognized by the system but I cannot get the system boot without the usb installer.

Booting via Enoch would result in KP: unable to find driver for this platform: \"ACPI\....blah...blah...blah :cry:
Last edited by Zlll on Wed May 17, 2017 7:13 am, edited 3 times in total.

This topic has 6 replies
You must be a registered member and logged in to view the replies in this topic.