Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.

 Advertising

User avatar
by: catdog
#46120
This fixes my shutdown/restart problems :)

My MOBO ASUS ROG-STRIX-X470-F-GAMING + Ryzen 7.

Only problem was the SMBIOS, I found that iMac14,4 works with Displayport. iMac14,4+ only showed up on my HDMI connected monitor.
#46386
AlGrey wrote:This guide will help you get native usb support for all USB ports on Ryzen motherboards. This will fix your issues with DACs/webcams/mics/BT dongles.

MAKE SURE THAT YOU HAVE A WORKING CLOVER ON YOUR USB DRIVE (usb installer you used to install macOS) AS THIS TUTORIAL CAN FAIL. BOOTING WITH THE CLOVER ON THE USB WILL MAKE THE USB PORTS WORK AGAIN (GenericUSBXHCI.kext is in /EFI/CLOVER/Kexts/**).

Automated version (thanks XLNC)
Spoiler:
1. Open the Terminal app.

2. Run the command :
Code: Select all
curl -s -o ~/Desktop/ryzenusbfix.sh https://raw.githubusercontent.com/XLNCs/ryzenusbfix/master/ryzenusbfix.sh && chmod +x ~/Desktop/ryzenusbfix.sh && ~/Desktop/ryzenusbfix.sh

3. Let the script do its magic.

4. Reboot and enjoy

NOTE : If you don't have a functional USB port to operate your MacOS (not keyboard or mouse working), use your bootable AMDHS_installer or HighSierraAMD USB to boot to your installed macOS drive. That will allow you to use your USB ports temporarily . Then you can run ryzenusbfix to fix your USB ports and boot without the USB installer.

Hi!
I do this method but now I can't boot, and the USB give me a error too in the file boot.efi... How can the USB stop working?
I have this from the first time I installed High Sierra on Ryzen and haven't any problem...

Any easy way to fix the USB and Boot to fix the problems?
#47031
I have a problem using this script, after using this script the computer can't shutdown. It always reboot after shutdown a few seconds :shock:
#47798
So, I followed the guide and tried both the newer and older patch. Most USB ports aren't working, although mouse and keyboard are ;) (thank god). Attached are my files, what am I missing?

Thanks!

Edit: I am running a Ryzen 2700x and ASUS X470 I-Gaming motherboard.
Post Merged
Anyone?? :cry:
You do not have the required permissions to view the files attached to this post.
#48012
@AlGrey, Thank your for your work! However, I met troubles using the Automated solution under my 10.14.4.
I fellow the instruction:https://vanilla.amd-osx.com/ to install my macOS, everything worked fine except all USB 2.0 ports.
It seems that the USB 2.0 controller is not recognized by the system.
I tried your Automated solution but it did not work, the system just seemed no change.
The problem just exist in USB 2.0 ports while the 3.0 and 3.1 ports are working just normal.
Would you please help me? Thank you!
屏幕快照 2019-05-14 09.32.06.png
屏幕快照 2019-05-14 09.31.25.png
config.plist.zip
You do not have the required permissions to view the files attached to this post.
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10

Can I get a hint as to how you got audio working? […]

Total AMD n00b - Vanilla Clover Patches?

Hey, do you remember how you went around to fixing[…]

Today I got my LAN kexts to work so I thought I'll[…]

Hey Guys, I am having this same problem. TransMac[…]