Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
#42714
Dmi Ser wrote:Hello! I have MSI B350 Gaming plus motherboard and none of my USB are working.
Here is my config.plist and DSDT.aml in 3 versions (i tried every fix (Ryzen USB OLD, Ryzen USB Fix, Ryzen USB Fix 2)).
I amd unable to do the ioregistry dump cause my usb is not working to the mouse and keyboard doesn't.
This forum says that my zip archive with dumps is too big, so i uploaded it to gdrive https://drive.google.com/file/d/1HXH-Na ... sp=sharing
I added DSDTs with all 3 fixes and original one.
Please, help!
From your IOReg you've still got GenericUSBXHCI there. Remove that for a start. Remove the USB injection settings in your config.plist and boot without a DSDT and run the script fresh.

 Advertising

#42715
Shaneee wrote:
Mon Sep 17, 2018 1:45 pm
Dmi Ser wrote:Hello! I have MSI B350 Gaming plus motherboard and none of my USB are working.
Here is my config.plist and DSDT.aml in 3 versions (i tried every fix (Ryzen USB OLD, Ryzen USB Fix, Ryzen USB Fix 2)).
I amd unable to do the ioregistry dump cause my usb is not working to the mouse and keyboard doesn't.
This forum says that my zip archive with dumps is too big, so i uploaded it to gdrive https://drive.google.com/file/d/1HXH-Na ... sp=sharing
I added DSDTs with all 3 fixes and original one.
Please, help!
From your IOReg you've still got GenericUSBXHCI there. Remove that for a start. Remove the USB injection settings in your config.plist and boot without a DSDT and run the script fresh.
I should remove this kext and load from usb to to all this stuff? Ether way i won't be able to do something cause my keyboard and mouse won't work.
By the way, i did the manual way.
Post Merged
Ok, i totally removed any usb injections and kexts from system booted from usb, did fresh DSDT.aml, patched it with Ryzen USB Fix and still no luck - after reboot nothing works.
Here is my debug files https://drive.google.com/file/d/168Movf ... sp=sharing
#42719
GenericUSBXHCI is still showing on your IOReg...
User avatar
by: AlGrey
#42722
Dmi Ser wrote:
Mon Sep 17, 2018 12:42 pm
Hello! I have MSI B350 Gaming plus motherboard and none of my USB are working.
Here is my config.plist and DSDT.aml in 3 versions (i tried every fix (Ryzen USB OLD, Ryzen USB Fix, Ryzen USB Fix 2)).
I amd unable to do the ioregistry dump cause my usb is not working to the mouse and keyboard doesn't.
This forum says that my zip archive with dumps is too big, so i uploaded it to gdrive https://drive.google.com/file/d/1HXH-Na ... sp=sharing
I added DSDTs with all 3 fixes and original one.
Please, help!
the DSDT in FIX looks good. The config is ok too.. just change it to SMBIOS to iMac18.3.. remove Genericusbxhci.kext and try ALL the ports
#42732
AlGrey wrote:
Tue Sep 18, 2018 2:40 am
Dmi Ser wrote:
Mon Sep 17, 2018 12:42 pm
Hello! I have MSI B350 Gaming plus motherboard and none of my USB are working.
Here is my config.plist and DSDT.aml in 3 versions (i tried every fix (Ryzen USB OLD, Ryzen USB Fix, Ryzen USB Fix 2)).
I amd unable to do the ioregistry dump cause my usb is not working to the mouse and keyboard doesn't.
This forum says that my zip archive with dumps is too big, so i uploaded it to gdrive https://drive.google.com/file/d/1HXH-Na ... sp=sharing
I added DSDTs with all 3 fixes and original one.
Please, help!
the DSDT in FIX looks good. The config is ok too.. just change it to SMBIOS to iMac18.3.. remove Genericusbxhci.kext and try ALL the ports
Changed SMBIOS to iMac18,3, removed Genericusbxhci and tried all the ports - still no luck, nothing works, none of them.
How can i make DSDT without Genericusbxhci? Cause of cource i can't move my mouse if system doesn't contain this kext at the moment when i exporting DSDT.
Maybe i should try fix 2 and old fix with this SMBIOS...
#42733
Your mouse will work in at least one port without the GenericUSBXHCI kext.
User avatar
by: Dmi Ser
#42737
Shaneee wrote:
Tue Sep 18, 2018 9:12 am
Your mouse will work in at least one port without the GenericUSBXHCI kext.
Than it might be another bug cause none of my usb ports are functional without GenericUSBXHCI kext.
Post Merged
Helly molly! Somehow my system is missing AppleUSBXHCIPCI.kext! Can somebody upload this kext in here? I am on High Sierra of course.
Post Merged
Ok, i am not missing it actually. So i tried every fix again - no luck, none of the usb ports are working. Sad. :(
Post Merged
Yea! I made it - finally working with AMD Ryzen Fix (with old fix and fix2 my system refused to boot). Everything works, but in USB it shows "AppleUSBXHCI Root Hub Simulation" - as one of the users already had. Don't know how to fix this. Somebody?
User avatar
by: AlGrey
#42752
you need to replace the original
/System/Library/Frameworks/CoreMediaIO.framework/Versions/A/Resources/VDC.plugin
/System/Library/SystemProfiler/SPUSBReporter.spreporter
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 11

Tp Link Tl-wn823n is USB and works out of the box

Problem at installation reboot

Looks like some files are missing from the install[…]

Help for install

If the disk is not showing up, in the same sceen w[…]

Have you tried injecting Lilu and Whatevergreen in[…]