Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.
#50980
Hi AlGrey,

I have added Ryzen USB in the MaciASL as a new source, but it didn't show up in Tools->Patch

Please see the attached screenshot
Screenshot 2019-09-03 at 7.10.29 PM.png
You do not have the required permissions to view the files attached to this post.

 Advertising

#51932
Worked perfectly on my system:
R5 1600 + GA-AB350M-D3H

Thanks :clap:
#52126
Does the fix still work on Catalina?
Tried on 10.15.1 and no luck
#52386
When you have time can you take a look to get it support for Mojave and Catalina please. I really appreciate.
#52663
When you have time can you take a look to get it support for Mojave and Catalina please. I really appreciate.
User avatar
by: fero-g
#53363
Hi @AlGrey,

I´ve tried every method but I always get the "Root Hub Simulation". I can't save the DSDT.aml file when I patch it manually. On the automated Version it occurs a error on the first method. I don't know what to do anymore.

Thank u in advance

Please find attached my files.
You do not have the required permissions to view the files attached to this post.
#53523
@Shaneee
That XLNCUSBFIX.kext partially works for me.
Can you tell me what part of the Info.plist I can tweak for my own board?

Edit: I installed GenericUSBXHCI.kext along side it and all of my USB ports work now!

So for anyone with a similar board to mine (Gigabyte GA-F2A88XM-D3H), you can get 100% working USB by installing XLNCUSBFIX.kext and GenericUSBXHCI.kext to your EFI kext folder and there is no need for ACPI/DSDT patches. Message me if you need a config.plist for Clover and 10.13.6.
  • 1
  • 8
  • 9
  • 10
  • 11
  • 12

Yes it's possible. I don't recommend using the sam[…]

Thanks for your post! I'm looking into replacing a[…]

Hello! I've been trying to get my OpenCore configu[…]

Fail. Not worked for nvidia gtx 1070