Welcome to AMD OS X

Why not register now to gain full access.

Tutorials for the installation and post install.

 Advertising

#36998
then no luck for you
#38011
Hi, I am a bit confused when determining fake device id to use.
My device id 0x6742. If i use fakeid 0x6839 (AMD5000Controller), the screen become blank after loading.
Can i try 0x6741 (AMD6000Controller)? Because 0x6741 doesn't have my graphic card.

Thanks in advance.
#38045
@Mustafa Salim,

Try editing your config.plist :
set INJECT ATI
Enable RadDeInit

If not working add:
FakeID = 0x68B81002
#38185
@AlGrey

First of all thanks for the help

But, here is my state now:
* Lilu and Whatevergreen already loaded (i check it with command `kextstat | grep vit`
* CSM and serial port already disabled (before disable my screen just 800x600, but now already support 1080)
* RadDeInit already enable (by using -radvesa and check raddeinit)
* If i disable INJECT ATI, load successful but graphic just loaded with 7mb ram and glitches
* If i enable INJECT ATI (RadDeInit disable), screen go blank after loading
* If i enable INJECT ATI (RadDeInit enable), screen just looping on this text
"IOConsoleUsers : time(0) 0->0, lln 0, llk 1,"
"IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0"
Note: i just wait about 10 second and then hard reset my computer, am i need to wait longer?
You do not have the required permissions to view the files attached to this post.
#38197
@Mustafa Salim,
No need to wait if you get that error.

Here is what you can try in your config :
1. Remove -radvesa or -radoff. No inject ATi, no RadDeInit, no fake id. In bios : CSM on, Serial IO always off. Keep Whatevergreen + lilu in /EFI/Clover/Kexts/xxxx (Other or 10.13).
2.A ) Add -radoff, Set InjectATI, RadDeInit, no fakeID. In bios : CSM disabled, Serial IO always off.
B) like A but add fake ID 0x68B81002
#38340
@AlGrey

This is my state after testing:
1. The screen just support 800x600 resolution
2. A) screen just looping on this text
"IOConsoleUsers : time(0) 0->0, lln 0, llk 1,"
"IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0"
B) Screen go blank

Is there hope if I try inject all faked id in AMD5000Controller ?
Or am I need to change my graphic card or other component ?
#38345
@Mustafa Salim,
Are you sure CSM is disabled and RadDeInit is enabled in 2A and B?
Try with fakeid = 0x68D91002
The previous fake id was in the wrong family (Juniper).. this one is the right one (Redwood).

Only if the new fake ID is not working.. I attached the two kexts modded for your GPU ID (0x67421002). Install with kext utility and try again.
You do not have the required permissions to view the files attached to this post.
#38352
@AlGrey,

Are you sure CSM is disabled and RadDeInit is enabled in 2A and B?
I already recheck, the CSM already disabled and RadDeInit is enabled, but the display go blank after early boot complete.

Try with fakeid = 0x68D91002
After applying new fakeid still no luck

After install new kext file i cannot boot to Mac, I don't know how to remove kext because the kext is installed to system/library/extension.
Now, i'm reinstalling the hackintosh. Will try again after it.
  • 1
  • 7
  • 8
  • 9
  • 10
  • 11
  • 14
Happy Holidays

Merry Christmas and happy new year Shanee and tha[…]

Can you help me ? What step did you take pre-insta[…]

Did you even try to run the script.. Because DSDT […]

Hello everyone. Today i tried to update my amdint[…]

AMD OS X Advertisements