• Is AMD kernel buggy?

  • Development and testing of modified XNU Kernels for AMD CPUs on OS X

Please remember to read and follow the rules here.

Please Donate or visit my Amazon Wishlist if you've found the website useful. Thanks.

Development and testing of modified XNU Kernels for AMD CPUs on OS X
#33641 by pink101
Fri Dec 01, 2017 2:27 pm
What do i mean by 'AMD kernel buggy'? well... here's my story...
FIrst of all, i'm not a programmer, but i'm really curious on installing osx on my AMD machine. So the first step to installing OSX on AMD is creating an installer. I did that and success on making it (the installer). Then After that, we install it on the hard drive. Now this is where i found it challenging. The short version of my experience is that i finally success installing OSX Yosemite 10.10.0 on my 16GB microSD card. It can boot and everything. After that, using disk utility i make dmg image of the system, then i transfer my system to my old 20GB IDE hardisk using IDEtoUSB converter. After that I boot my Yosemite using my old 20GB drive from USB. Now this is the buggy part... It can boot like the one on microSD, but after +/- 3 second it then hang with spinning ball, but that's not what bug me, the problem is that when i restart the system, the hfsplus partition become corrupt and cannot be fixed by disk utility. I tried it many times with both 10.10.0 and 10.10.5 with many different kernels and the partition is always corrupt after hang. Why i suspect that it was the AMD kernel? Because when i tried it on intel machine, not only that my old 20GB disk can boot successfully, but also when i hit reset on my intel machine, the partition didn't become corrupt like it was on my AMD machine.
I'm curious if anybody have the same experience as i do? btw, here's post about my AMD system

PS: To admin, if this is the wrong section to post this topic please move it to the right section, thank you...


#33647 by Norton287
Fri Dec 01, 2017 3:55 pm
Its because you're using IDE, the drive needs to be set to AHCI

#33680 by pink101
Sat Dec 02, 2017 5:48 am
Norton287 wrote:Its because you're using IDE, the drive needs to be set to AHCI
Not really... im using my IDE drive through a USB converter, and if that's really the reason, then why on Intel system the hardisk work just fine?
#33685 by Norton287
Sat Dec 02, 2017 3:01 pm
This is amd not intel
Egress liked this

#34216 by pink101
Sun Dec 10, 2017 11:05 am
Just bought IDE to sata converter, now the problem no longer exist.... i can still use my IDE hardisk as a test drive for Hackintosh and both hang problem and partition corrupt problem seems no longer exist...