[WIP] ROG Zephyrus G14 2022 (GA402RJ) R7 6800HS + RX 6700S

ccr4700

New member
Joined
Aug 12, 2020
Messages
8
Hi, I've been trying to install Monterey to ROG Zephyrus G14 laptop these days, and found many tricks to get it working.

Currently not all functions and components work properly ( especially trackpad ), but many important components like CPU and GPU working.
Please check working and not working sections below and tell me if you find solutions to solve problems. And I hope my configurations help who struggling with Ryzen laptops.


176993855-832f4ff0-b2c8-41f3-88fc-7c35c2f7bd3b.png


Model : GA402RJ ( GA402RK should work too )
CPU : AMD Ryzen 7 6800HS 3.2 GHz ( Rembrandt )
dGPU : AMD Radeon RX 6700S 8 GB ( Navi23 )
Memory : DDR5-4800MHz 16 GB ( 8 GB onboard + 8 GB SO-DIMM )
SSD : Crucial P5 Plus Gen4 1TB ( replaced from original Micron 512GB )
WiFi : Intel AX210 WiFi 6 ( replaced from original MediaTek M.2 2230 card )

My EFI is uploaded to this github repo.

Working
  • CPU with 8 cores and 16 threads enabled
  • dGPU acceleration
  • WiFi ( card replacing required )
  • PCIe 4.0 NVMe SSD
  • All USB ports
  • Keyboard
  • Internal speaker ( Sound quality is too bad )
  • Battery status
  • Integrated camera
Not working / Problems
  • Radeon 680 iGPU ( Probably never works )
  • Trackpad ( I2C controlled, no idea to enable AMD I2C device )
  • Sleep / Hibernation
  • Hardware video decode / encode acceleration
  • Hardware LCD backlight brightness control
  • Keyboard backlight brightness control ( Always on )
  • Keyboard Fn hotkeys ( Only sound hotkeys work )
  • macOS Ventura beta ( Stuck at ACPI: sleep states )
  • Vanilla IOPCIFamily.kext / AppleACPIPlatform.kext ( Must be replaced with Big Sur's one )
  • Longer battery life ( only runs for around an hour and a half )
 

Attachments

  • ioreg_GA402.zip
    767.8 KB · Views: 6
Last edited:

Middleman

Active member
Joined
Jan 29, 2021
Messages
423
Congrats on your build! That’s probably the first 6700 based system I’ve seen working properly. You should have full 3D acceleration from what I gather.

Have you done a AGDCDiagnose output? Would be interesting to see what it shows.

Regarding your trackpad you will need the following enabled (in this order):

SSDT-GPIO.aml
VoodooI2C
VoodooPS2Controller
VoodooI2CHID
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
911
Battery - ECEnabler.kext + SMCBatteryManager.kext (works for Intel systems).

SMCBatteryManager.kext is one of the kexts bundled with VirtualSMC.kext. You need to use the same version of the SMCBatteryManager.kext as you are using VirtualSMC.kext.

ECEnabler.kext can be obtained from this GitHub page:


Brightness control - use Acidanthera's BrightnessKeys.kext


You may also need to add SMCLightSensor.kext, another kext bundled with VirtualSMC.kext.

Not sure you should be using the old SSDT-PLNF.aml. That SSDT was created for for pre-Coffee Lake Intel laptops that use an Intel iGPU. Your system shouldn't be using the AMD IGPU so shouldn't in theory require that SSDT, or the newer CFL version. I can't recall if WhateverGreen.kext incorporated the PLNF fix. Maybe someone with a better memory than me can pipe up about this.

I am not sure that using a desktop SMBIOS (MacPro7,1) is correct either. You may be better served using a MacBookPro16,1, or 16,4.

I am not sure that macOS contains the correct settings for your RX6700S GPU.
You may have to fake the device ID of another Navi 23 card, such as the W6600, which has the same number of shaders but a different base clock speed as your 8GB RX6700S and is supported natively.

The Ven/Dev ID for the W6600 is 1002:73E3, you are already faking the device-id with that of the RX6600 1002:73FF. Using the alternative might help with some of the graphics issues you are facing.

 

zxc2689963

Member
Joined
Feb 27, 2022
Messages
62
Thank you for sharing, my Legion 5 has been stuck on cpus=1 for several months, it is not clear why, do you encounter kernel Panic when Monterey is booted by 8 core cpus? I saw that you said to replace BigSur's Vanilla iopcifamily. kext/appleacpiplata. kext to Monterey, and I have also considered this option
 

ccr4700

New member
Joined
Aug 12, 2020
Messages
8
Battery - ECEnabler.kext + SMCBatteryManager.kext (works for Intel systems).

SMCBatteryManager.kext is one of the kexts bundled with VirtualSMC.kext. You need to use the same version of the SMCBatteryManager.kext as you are using VirtualSMC.kext.

ECEnabler.kext can be obtained from this GitHub page:


Brightness control - use Acidanthera's BrightnessKeys.kext


You may also need to add SMCLightSensor.kext, another kext bundled with VirtualSMC.kext.

Not sure you should be using the old SSDT-PLNF.aml. That SSDT was created for for pre-Coffee Lake Intel laptops that use an Intel iGPU. Your system shouldn't be using the AMD IGPU so shouldn't in theory require that SSDT, or the newer CFL version. I can't recall if WhateverGreen.kext incorporated the PLNF fix. Maybe someone with a better memory than me can pipe up about this.

I am not sure that using a desktop SMBIOS (MacPro7,1) is correct either. You may be better served using a MacBookPro16,1, or 16,4.

I am not sure that macOS contains the correct settings for your RX6700S GPU.
You may have to fake the device ID of another Navi 23 card, such as the W6600, which has the same number of shaders but a different base clock speed as your 8GB RX6700S and is supported natively.

The Ven/Dev ID for the W6600 is 1002:73E3, you are already faking the device-id with that of the RX6600 1002:73FF. Using the alternative might help with some of the graphics issues you are facing.

I forgot to add about battery status to the post but you can confirm the battery is working according to screenshots and EFI, so I hope you to look my EFI at github. ( battery status added to the post ).

BrightnessKeys.kext just enable backlight hotkeys, not enabling brightness control function itself, so I don't reach the phase that this kext is needed.

Currently SSDT-PNLF.aml only changes AppleDisplay to AppleBacklightDisplay in ioreg, so I'm not sure it is needed or not.

MacPro7,1 is the only bootable smbios I found. iMacPro1,1, MacBookPro16,1 and 16,4 isn't bootable with dGPU accelaration enabled.
Even if GA402 is a laptop, I think that MacPro7,1 or iMacPro1,1 smbios are suitable for the pc without iGPU ( because AMD iGPUs don't work ).

I tested 73E3 spoofing but nothing changed compared with 73FF. These device ids are listed on same IOPCIMatch in AMD kexts, so there is no difference bitween them theoretically.

Thank you for sharing, my Legion 5 has been stuck on cpus=1 for several months, it is not clear why, do you encounter kernel Panic when Monterey is booted by 8 core cpus? I saw that you said to replace BigSur's Vanilla iopcifamily. kext/appleacpiplata. kext to Monterey, and I have also considered this option

I had stuck at early kernel panic that is described in the post below.
I had to modify and replace APIC.aml to solve the problem, but another fix was not required to all cpu cores to be recognized.

I don't know modifying APIC.aml helps to solve cpus=1 issue, because the early KP may be a ASUS related issue rather than a AMD related.
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
911
Can you post a copy of your IOReg, using the version attached in the link below. Don't use a newer version of IORegistryExplorer as they tend to corrupt the IOReg so it can't be read on another system.


I see you changed the 'Local Apic ID' in the APIC.aml table, to match the 'Processor ID'. Did that fix the CPU, so all cores/threads would work in macOS?

Screenshot 2022-07-03 at 14.19.41.png Comparing System APIC.aml and modified APIC.aml first 8-threads

Screenshot 2022-07-03 at 14.23.30.png Comparing System APIC.aml and modified APIC.aml last 8-threads
 

ccr4700

New member
Joined
Aug 12, 2020
Messages
8
Can you post a copy of your IOReg, using the version attached in the link below. Don't use a newer version of IORegistryExplorer as they tend to corrupt the IOReg so it can't be read on another system.


I see you changed the 'Local Apic ID' in the APIC.aml table, to match the 'Processor ID'. Did that fix the CPU, so all cores/threads would work in macOS?

View attachment 6464 Comparing System APIC.aml and modified APIC.aml first 8-threads

View attachment 6465 Comparing System APIC.aml and modified APIC.aml last 8-threads

I attached the ioreg to the op of this thread.

I see you changed the 'Local Apic ID' in the APIC.aml table, to match the 'Processor ID'.
No. I changed the Processor ID to match the Local Apic ID.
It is also described in my github repo. Again, I hope you to look my repo.
 

Jo-Toku

Donator
Donator
Joined
Dec 29, 2021
Messages
123
Hi, I've been trying to install Monterey to ROG Zephyrus G14 laptop these days, and found many tricks to get it working.

Currently not all functions and components work properly ( especially trackpad ), but many important components like CPU and GPU working.
Please check working and not working sections below and tell me if you find solutions to solve problems. And I hope my configurations help who struggling with Ryzen laptops.


176993855-832f4ff0-b2c8-41f3-88fc-7c35c2f7bd3b.png


Model : GA402RJ ( GA402RK should work too )
CPU : AMD Ryzen 7 6800HS 3.2 GHz ( Rembrandt )
dGPU : AMD Radeon RX 6700S 8 GB ( Navi23 )
Memory : DDR5-4800MHz 16 GB ( 8 GB onboard + 8 GB SO-DIMM )
SSD : Crucial P5 Plus Gen4 1TB ( replaced from original Micron 512GB )
WiFi : Intel AX210 WiFi 6 ( replaced from original MediaTek M.2 2230 card )

My EFI is uploaded to this github repo.

Working
  • CPU with 8 cores and 16 threads enabled
  • dGPU acceleration
  • WiFi ( card replacing required )
  • PCIe 4.0 NVMe SSD
  • All USB ports
  • Keyboard
  • Internal speaker ( Sound quality is too bad )
  • Battery status
  • Integrated camera
Not working / Problems
  • Radeon 680 iGPU ( Probably never works )
  • Trackpad ( I2C controlled, no idea to enable AMD I2C device )
  • Sleep / Hibernation
  • Hardware video decode / encode acceleration
  • Hardware LCD backlight brightness control
  • Keyboard backlight brightness control ( Always on )
  • Keyboard Fn hotkeys ( Only sound hotkeys work )
  • macOS Ventura beta ( Stuck at ACPI: sleep states )
  • Vanilla IOPCIFamily.kext / AppleACPIPlatform.kext ( Must be replaced with Big Sur's one )
  • Longer battery life ( only runs for around an hour and a half )


Can you download Geekbench 5 and test the GPU 6700s. On the Legion 5 Monterey I get 61k on OpenCL and Metal. The 6700s is basically the same as the 6600m while the 6800s is closer to the 6700m

Here is my test score of the GPU on Metal. (BTW, this is a very good score)

S__3858439.jpeg
 
Last edited:

Didibombik

New member
Joined
Jun 30, 2022
Messages
1
Can you download Geekbench 5 and test the GPU 6700s. On the Legion 5 Monterey I get 61k on OpenCL and Metal. The 6700s is basically the same as the 6600m while the 6800s is closer to the 6700m

Here is my test score of the GPU on Metal. (BTW, this is a very good score)

View attachment 6493
Hey there!
Can you help me a little please? I have a Lenovo Legion 5 5600h and 6600m, almost the same config as yours, but I am getting stuck on Apple logo with infinite loading bar. Can you tell me what have you changed in this Zephyrus build to get it boot up on Lenovo besides intel kexts and some other obvious little things?
Thank you for your time!
 

Jo-Toku

Donator
Donator
Joined
Dec 29, 2021
Messages
123
Hey there!
Can you help me a little please? I have a Lenovo Legion 5 5600h and 6600m, almost the same config as yours, but I am getting stuck on Apple logo with infinite loading bar. Can you tell me what have you changed in this Zephyrus build to get it boot up on Lenovo besides intel kexts and some other obvious little things?
Thank you for your time!
Follow the following thread. Everyone there have the Legion 5 and trying to get it working properly. You can use the EFI from post 98, but there are a lot of variation EFI as there is further development. You should start reading from the start

Thread: https://forum.amd-osx.com/index.php?threads/amd-rayon-r7-5800h-install-monterey-kernel-panic.2725/
 

ccr4700

New member
Joined
Aug 12, 2020
Messages
8
Can you download Geekbench 5 and test the GPU 6700s. On the Legion 5 Monterey I get 61k on OpenCL and Metal. The 6700s is basically the same as the 6600m while the 6800s is closer to the 6700m

Here is my test score of the GPU on Metal. (BTW, this is a very good score)

View attachment 6493

My result uploaded to here.
Metal : 51236 ( https://browser.geekbench.com/v5/compute/5087109 )
OpenCL : 42898 ( https://browser.geekbench.com/v5/compute/5087110 )
OpenCL(Windows) : 72912 ( https://browser.geekbench.com/v5/compute/5053040 )

Not so good as expected compared with Windows, I don't know the reason.
I tested PP_PhmSoftPowerPlayTable injection but it seems not working.
 

redhorse1990

New member
Joined
Jul 2, 2022
Messages
3

Jo-Toku

Donator
Donator
Joined
Dec 29, 2021
Messages
123
My result uploaded to here.
Metal : 51236 ( https://browser.geekbench.com/v5/compute/5087109 )
OpenCL : 42898 ( https://browser.geekbench.com/v5/compute/5087110 )
OpenCL(Windows) : 72912 ( https://browser.geekbench.com/v5/compute/5053040 )

Not so good as expected compared with Windows, I don't know the reason.
I tested PP_PhmSoftPowerPlayTable injection but it seems not working.
Interesting the result are lower than the 6600m, only some memory difference. Although 51k is not low at all
 

namquang93

New member
Joined
May 9, 2022
Messages
1
Amazing work. I'm having a Razer Blade 15 2020 running Monterey 12.4 but looking at this makes me think about selling my RZB & buy a G14 2022 because I only have Intel HD 630 on macOS.
 

Jo-Toku

Donator
Donator
Joined
Dec 29, 2021
Messages
123
Amazing work. I'm having a Razer Blade 15 2020 running Monterey 12.4 but looking at this makes me think about selling my RZB & buy a G14 2022 because I only have Intel HD 630 on macOS.
Seems the g14 is the current best besides the Alienware Area 51, R2 with the RX 5700m, but are rare to find. The HP Zbook with the 11th gen CPU and the w6600m also is a good option and larger size screen if you want a larger form factor than 14 inches
 
Last edited:

CNGZ2022

New member
Joined
Jul 11, 2022
Messages
9
Can you download Geekbench 5 and test the GPU 6700s. On the Legion 5 Monterey I get 61k on OpenCL and Metal. The 6700s is basically the same as the 6600m while the 6800s is closer to the 6700m

Here is my test score of the GPU on Metal. (BTW, this is a very good score)

View attachment 6493
Hello, is this a Lenovo R7000P-RX6600M machine? Is your CPU all working properly?
 

Jo-Toku

Donator
Donator
Joined
Dec 29, 2021
Messages
123
Hello, is this a Lenovo R7000P-RX6600M machine? Is your CPU all working properly?
My results are from the Lenovo Legion 5 with the RX 6600M. Nope still have the one core limitation under Monterey. The Asus Zhephyrus g14 seem to not have that problem
 
Top Bottom