Unable to change install Language

DAFFY

Member
Joined
May 12, 2020
Messages
57
Ok, I do have the option to use DVI. I'll give it a try along with the new EFI you posted. Thanks...
 

DAFFY

Member
Joined
May 12, 2020
Messages
57
So I tried that new EFI and both DVI ports on my GTX 760 without any adapters and still get the black screen before Pick List.
 
Last edited:

DAFFY

Member
Joined
May 12, 2020
Messages
57
So I've got to the install screen using the "EFI 0.8.1 FX" EFI you sent and replaced HfsPlus.efi with HfsPlusLegacy.efi but im stuck on what looks like a German Installer and my mouse and keyboard don't work.

EDIT: I've injected USBInjectAll.kext and cleared my NVRam now my installer is in English but still my mouse and keyboard don't work in the installer
 
Last edited:

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
910
You may need to remove GenericUSBXHCI.kext from the OC 0.8.1 FX /OC/Kexts folder and config.plist. This kext has been obsolete since El Capitan on Intel Systems, so I don't think it will be any better on an AMD system. I have never used it on my AMD FX system.

Same goes for USBInjectAll.kext, it has never worked on an AMD system. It is configured solely to work with Intel USB controllers, which our AMD systems don't use.

Sometimes less is better.
 

DAFFY

Member
Joined
May 12, 2020
Messages
57
So got Catalina installed but only my rear USB 3.0 ports work. I've tried every port on the rear..
 

DAFFY

Member
Joined
May 12, 2020
Messages
57
Hi Ed, I've not changed any kexts or plist settings from what was included in 0.8.1 FX EFI you uploaded..
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
910
Ok, that means the GenericUSBXHCI.kext is present and enabled in your system.

Did you add your Serial Number etc. to the config.plist?

Try this EFI 0,.8.1 FX 2 folder. The only change is the removal of the GenericUSBXHCI.kext from the Kexts folder and config.plist. This kext didn't help with my FX system's USB ports, so I doubt it will help with yours.

You need to add the MLB, ROM, Serial Number and SystemUUID to the revised config before you use it.
 

Attachments

  • EFI 0.8.1 FX 2.zip
    4 MB · Views: 14

DAFFY

Member
Joined
May 12, 2020
Messages
57
So without the GenericUSBXHCI.kext my two USB 3.0 ports don't work either. Yes I've added serial info
 
Last edited:

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
910
This is the same EFI. See if this will download.
 

Attachments

  • EFI 0.8.1 FX 2.zip
    4 MB · Views: 13

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
910
Sorry the download has stalled for me too. Not sure why, but I had a similar issue with someone else's EFI when trying to download it.

Maybe @Shaneee can tell us what is happening with the site hosting and downloads.

I've sent you a PM with a link to the EFI on my OneDrive.
 

DAFFY

Member
Joined
May 12, 2020
Messages
57
after dong some reading I found a post where there was an SSDT which was blocking the USB ports on the system. Could this be the problem here
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
910
Which SSDT?

You only have two SSDT's in your /EFI/OC/ACPI folder - SSDT-EC-USBX-AMD.aml and SSDT-XOSI.aml. Neither of those SSDT's are going to adversely affect your USB ports.

The SSDT-XOSI.aml is from Rehabman's OS-X-USB-Inject-All-master folder. This can be removed and the companion ACPI patch in the config.plist too, if you want to see if that makes any difference.

The SSDT-EC-USX-AMD.aml adds the fake EC device and provides USB power settings. You need both aspects of this SSDT as you are using a SMBIOS that doesn't have the USB power settings in macOS. Removing this would be a bad idea, as the system would kernel panic.

You could use two separate SSDT's for the fake EC device and USB power settings. Or use Dortania's catch all SSDT.
 
Top Bottom