SSDT for Flashed GC-Titan Ridge

CaseySJ

Guru
Guru
Donator
Joined
May 10, 2020
Messages
1,285
@avx117,

Attached is a Thunderbolt SSDT for you to try with the flashed GC-Titan Ridge. It assumes the card is in the bottom long slot, but if it's somewhere else we can just modify the PCI path accordingly. The two files attached in the ZIP are used together. If you already have SSDT-DTPG.aml in your OC/ACPI folder then it's not necessary to replace it.
 

Attachments

  • SSDT-for-bottom-slot-X570-Taichi.zip
    2.5 KB · Views: 63

avx117

New member
AMD OS X Member
Joined
May 2, 2020
Messages
11
@avx117,

Attached is a Thunderbolt SSDT for you to try with the flashed GC-Titan Ridge. It assumes the card is in the bottom long slot, but if it's somewhere else we can just modify the PCI path accordingly. The two files attached in the ZIP are used together. If you already have SSDT-DTPG.aml in your OC/ACPI folder then it's not necessary to replace it.

Thank you @CaseySJ
This also requires that I change the DROM following the instructions in the other thread, correct?
 

CaseySJ

Guru
Guru
Donator
Joined
May 10, 2020
Messages
1,285
Thank you @CaseySJ
This also requires that I change the DROM following the instructions in the other thread, correct?
I've already modified the DROM for you, so it's just plug-and-play.

By the way, have you considered using the N-D-K fork of OpenCore because you're dual booting macOS and Windows? The N-D-K fork will not inject SSDTs when booting Windows, which is similar to Clover in that SSDTs in ACPI folder will only be applied to macOS. Hence no need for _OSI ("Darwin").

Your existing config.plist is usable with N-D-K fork, but we just need to add two parameters:
  • ACPI --> Quirks --> EnableForAll --> True
  • Booter --> Quirks --> EnableForAll --> True
Screen Shot 2020-05-11 at 1.40.53 PM.png
 
Last edited:

avx117

New member
AMD OS X Member
Joined
May 2, 2020
Messages
11
I've already modified the DROM for you, so it's just plug-and-play.

By the way, have you considered using the N-D-K fork of OpenCore because you're dual booting macOS and Windows? The N-D-K fork will not inject SSDTs when booting Windows, which is similar to Clover in that SSDTs in ACPI folder will only be applied to macOS. Hence no need for _OSI ("Darwin").

Your existing config.plist is usable with N-D-K fork, but we just need to add two parameters:
  • ACPI --> Quirks --> EnableForAll --> True
  • Booter --> Quirks --> EnableForAll --> True
View attachment 189
Thank you. I now have the system functioning well, except for hot plug not fully working. @iGPU had posted a SSDT for the gigabyte board, that is similar but not the exact same. Since I'm not as in tune with .aml files, what adjustments are made with @iGPU .aml file compared to the one you posted? Would it improve hotplug?
 

Attachments

  • SSDT-TBOLT3-RP05-PORT7-GC-TITAN-RIDGE-test.aml.zip
    1.7 KB · Views: 30

avx117

New member
AMD OS X Member
Joined
May 2, 2020
Messages
11
I tried a modified @iGPU SSDT for my MB which did not work. The issue I have is that when I plug in my ThunderRaid3 once in MacOS, the hard drives are not recognized by catalina. Alternatively, if I leave it plugged in from boot, it works, but if I unplug after booting to MacOS and attempt to re-plug back in, it does not work. Any ideas @CaseySJ ?
 

iamso78

New member
AMD OS X Member
Joined
May 12, 2020
Messages
21
@avx117,

Attached is a Thunderbolt SSDT for you to try with the flashed GC-Titan Ridge. It assumes the card is in the bottom long slot, but if it's somewhere else we can just modify the PCI path accordingly. The two files attached in the ZIP are used together. If you already have SSDT-DTPG.aml in your OC/ACPI folder then it's not necessary to replace it.

Follow this guide and flashed TitanRidgeNVM23-E64Fr.zip, few observations on x570 Taichi

Bios settings:
  • TB enabled
  • no security

1) 86 error code
2) 5A error code when LG 5k display and mini display ports connected
3) hot plug doesnt work
4) LG 5k display doesnt work at all (hot/cold plug)

any clues what I am doing wrong?

UPDATE:
TB disabled in Bios clear all boot errors. LG 5k display still doesnt function properly, was able to to get Video signal by itself or Audio/USB-C/Webcam working by itself, but cannot get fully functionality eg video/audio/usbc/webcam working at same time.

hot plug still doesnt work regardless of TB devices. Reverting back to original ROM.
 

Attachments

  • TitanRidgeNVM23-E64Fr.zip
    267.1 KB · Views: 19
Last edited:

slehc84

Member
AMD OS X Member
Joined
Jul 5, 2020
Messages
56
Sorry for a silly question , do you have to flash the Titan , to make it work ? does it not work OOB , I can get my Samsung TB monitor working and sometimes the sound, but before I buy a dock I need to get it all working
 
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.