Real Thunderbolt 3 at 40Gb/s Titan Ridge v2


New member
Apr 24, 2021
@Arrakis, thank you, I tried using your SSDT, but as APCI paths for thunderbolt are different on my system it would not work. In the end I was able to solve this though!

When using your SSDT, the System Report in the Thunderbolt section would just read "No Thunderbolt Hardware found", instead of "No Driver Loaded".
So I understood the issue was not really with the SSDT, that was already working in Catalina, but with the drivers of my Thunderbolt Audio interface.

Compatible Big Sur drivers were released lately, and while in Catalina there was a .Kext, in Big Sur they're based on some different system extensions (I could not find any .kext file under Library/Extensions). However both didn't work on my system, and the Catalina .kext would also not work directly in Big Sur.
But in the end I tried injecting the .kext that was working in Catalina directly though OpenCore, and in that case it does work!

So now my PCI section looks like this (Thunderbolt shows there, with driver installed, together with the Audio interface connected via Thunderbolt).
Schermata 2021-04-25 alle 19.35.27.png

And looking at the Audio Interface menu, it also reports "Connected via Thunderbolt" and Audio functions correctly, so Thunderbolt is definitely working.
Strangely, in system report, "Thunderbolt" still shows "No Driver Loaded"... but I guess I can live with that!
Schermata 2021-04-25 alle 19.27.15.png
Last edited:
Top Bottom