macOS Sequoia

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,505
Also Acidanthera have released an updated AirportBrcmFixup.kext that is supposed to work with Sequoia.

See zipped Artefacts folder below containing v2.1.9 for Sequoia.
 

Attachments

  • Artifacts.zip
    123.4 KB · Views: 10

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,505
Handoff from my iPad Air 5 to my Intel Z87 Hack running Sonoma 14.5 works, with Intel AX210 WiFi/BT card (Itlwm.kext + Heliport).

The same system booting Sequoia beta 2 doesn't work the same, even though all the settings & kexts are identical for both OS's. Probably due to Bluetooth not working in Sequoia.
 

Davey076

New member
AMD OS X Member
Joined
Nov 23, 2021
Messages
10
Also Acidanthera have released an updated AirportBrcmFixup.kext that is supposed to work with Sequoia.

See zipped Artefacts folder below containing v2.1.9 for Sequoia.
Replaced the kext and added max kernel to AMFIPass. Thanks!IMG_2911.jpeg
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
2,211
@Edhawk here's the kexts for Intel BT I updated for Sequoia
 

Attachments

  • Intel_BT_Sequoia.zip
    10.9 MB · Views: 12

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,505
@Shaneee I am using them. I saw your link for these kexts over on Insanely Mac earlier today.

Replacing the original Intel BT kexts, clearing Nvram etc. didn’t make any difference to the Bluetooth working in Sequoia beta 2.

I will try again tomorrow and let you know if anything changes, thanks.
 

craighazan

Donator
Donator
Joined
Nov 22, 2021
Messages
392
The Intel BT kexts for Sequoia stopped working for me too, my 5700U and 4700G, both on Beta 2, won't connect anymore. I have got sound from the GenMachine using AppleACLU, but not on the 4700G!.
 

Steve901

New member
AMD OS X Member
Joined
Jul 30, 2023
Messages
27
WechatIMG38.jpg
1720318921403.png

1720318994022.png

Hi Guys, could use some help.
AMD CUP patch has been applied.

Sonoma was no issue.
Panic found when upgrade to Suqoia.
 

Phoenix

New member
AMD OS X Member
Joined
May 12, 2020
Messages
20
14.5 sonoma works flawlessly with his EFI.
But stuck when I want to upgrade to Sequoia.
When it starts the Installer after boot I just see:
 

Attachments

  • EFI 3.zip
    13.6 MB · Views: 10
  • IMG_7239.jpeg
    IMG_7239.jpeg
    2.3 MB · Views: 10

craighazan

Donator
Donator
Joined
Nov 22, 2021
Messages
392
14.5 sonoma works flawlessly with his EFI.
But stuck when I want to upgrade to Sequoia.
When it starts the Installer after boot I just see:
Because your Patches are out of date, Shaneee updated them for Sequoia.

 

craighazan

Donator
Donator
Joined
Nov 22, 2021
Messages
392
@Steve901 attach your EFI after removing SMBIOS info first.
 

craighazan

Donator
Donator
Joined
Nov 22, 2021
Messages
392

Hi, craighazan, Thanks for your help. pls take a look at my EFI.​

The only question I would raise is, why do you have DSDT.aml in your ACPI folder?. Your config.plist looks fine to me, latest patches and SecureBoot > Disabled. I would maybe try adding boot arg 'revpatch=cpuname,pci,sbvmm', I used it with my first installation of Sequoia.
Screenshot 2024-07-07 at 9.28.12 AM.png
 

craighazan

Donator
Donator
Joined
Nov 22, 2021
Messages
392
Your Config only has 19 patches, Shaneees latest patches for Sequoia has 25.Screenshot 2024-07-07 at 5.05.19 PM.png
 

pterodactylstfw

New member
AMD OS X Member
Joined
Jul 8, 2024
Messages
1
Hello! Does anyone know how to fix my issue? I have the latest kexts and I am using OpenCore 1.0.0 DEBUG and my computer is still stopping with the Memory Panic issue. I have the latest AMD Kernel Patches, and my setup is 3600X with 5600XT. Any tip is helpful.
 

Attachments

  • EFI.zip
    12.3 MB · Views: 3
  • opencore-2024-07-08-171945.txt
    256 KB · Views: 3

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
2,211
Guys please remember that we don't officially support Beta versions of macOS. Yes the patches are available but not everything has been updated to work correctly yet.
When Apple release the first finished version of macOS 15 then the Sequoia sub-forums will be unlocked and support provided.
Keep this topic for general chit chat about the upcoming version.
 

Edhawk

Guru
Guru
Joined
May 2, 2020
Messages
2,505
@Steve901 When running macOS you need to look at the kexts you have enabled, or rather at two you have disabled in your setup.

1720318921403.png The two kexts highlighted in RED need to be enabled.

Also for Sequoia you need to add the following boot arguments.

-lilubeta -vsmcbeta -alcbeta

You don't have WhateverGreen.kext or NootRX.kext in your OC setup for your RX 6600 dGPU. So no graphics boot arguments are required. Personally I would include one or the other of these kexts. WhateverGreen.kext being eh better option due to your use of DeviceProperties for your 2 x Network devices.

I have assumed you have disabled the AMD Integrated GPU (Radeon graphics). So you do not need the igfxonin=1 entry as this an Intel IGPU boot argument

Your SSDT-HPET.aml table in your ACPI folder is useless without the ACPI patches generated at the same time as the SSDT. The patches need to be added to your config.plist for the SSDT to work.

Your MSI 450M A Pro Max motherboard doesn't need SSDT-CPUR.aml. Only the B550 and A520 motherboards require that SSDT.

As you have a custom USBPorts.kext you should not be using/enabling the XhciPortLimit entry in the config.plist.

Here is a revised SSDTTime Results folder for your system, based on the DSDT.aml that was present in your /EFI/OC/ACPI folder. It contains all the SSDT's (.aml tables) you need for your setup along with the SSDT-HPET.aml patches in the patches_OC.plist.
 

Attachments

  • Results.zip
    6.2 KB · Views: 2

wilianb

New member
AMD OS X Member
Joined
Jul 26, 2021
Messages
19
Se instaló correctamente la versión beta 15 en una PC ASUS X570-Ryzen 3600-VGA RX 5700XT

Gracias al administrador de AMD Kenel Path Beta.

View attachment 14322
yoola puedes subir tu EFI para tener un ejemplo ya que tengo la misma placa base y me gustaria experimentar con Sequoia.
 

Moozuki

Active member
AMD OS X Member
Joined
May 3, 2020
Messages
207
Beta 3

Screenshot 2024-07-10 at 3.41.29 PM.png
Still no audio
Still no Bluetooth
Intel WiFi works
EFI attached in case anybody wants to look at it, don't know what I'm doing wrong, if anything at all.
 

Attachments

  • EFI OC 10 A520m-DS3H.zip
    44.1 MB · Views: 12
Last edited:
Back
Top Bottom
  AdBlock Detected
Sure, ad-blocking software does a great job at blocking ads, but it also blocks some useful and important features of our website. For the best possible site experience please take a moment to disable your AdBlocker.