USB Map for GB X570 AORUS Pro MB

gopal334

New member
May 2, 2020
13
2
3
Greetings,
Would anyone please share the USB mapped SSDts for Gigabyte X570 Pro wifi Motherboard.
Just need it as a reference.
Thanks in advance.
 

f_ender

New member
May 6, 2020
6
1
3
Hi Gopal334,

Would you be able to post your EFI folder please?

I've got GB X570 I AORUS Pro Wifi (rev 1.0) and trying to install latest MAC OSX on it.
I'm fresh to hackintosh on AMD and so far no luck with OC bootloader.

Cheers,
F
 

gopal334

New member
May 2, 2020
13
2
3
Hi Gopal334,

Would you be able to post your EFI folder please?

I've got GB X570 I AORUS Pro Wifi (rev 1.0) and trying to install latest MAC OSX on it.
I'm fresh to hackintosh on AMD and so far no luck with OC bootloader.

Cheers,
F
I have attached my EFI. Please change the SMBIOS / Product Serial. OC Version is 0.57. Please let me know if it worked for you.
I have a NVME SSD, RX5700 and Fenvi T919.
Gopal
 

Attachments

f_ender

New member
May 6, 2020
6
1
3
Hi Gopal334,

Thanks for the folder it was very helpful. I did manage to get my boot USB working and now getting the Cartalina to install.
Not sure if this is the right place to talk about what happens next :)
I'm hitting some issue after reboot. After installation I'm booting second time from USB to load the installer on the SSD. It starts booting gets into the apple icon with the bar in graphics mode then it crashes with TRACE in the LOG - Installer Log 6-May-2020_2.log.zip

I've also attached my EFI folder if someone can suggest what to change to get it working.

Thanks in advance.
F_ender
 

Attachments

  • Like
Reactions: gopal334

gopal334

New member
May 2, 2020
13
2
3
Hi Gopal334,

Thanks for the folder it was very helpful. I did manage to get my boot USB working and now getting the Cartalina to install.
Not sure if this is the right place to talk about what happens next :)
I'm hitting some issue after reboot. After installation I'm booting second time from USB to load the installer on the SSD. It starts booting gets into the apple icon with the bar in graphics mode then it crashes with TRACE in the LOG - Installer Log 6-May-2020_2.log.zip

I've also attached my EFI folder if someone can suggest what to change to get it working.

Thanks in advance.
F_ender
You may get some help from the experts @discord.
 

gopal334

New member
May 2, 2020
13
2
3
I'm lost with the next step of this SSDT. What is the process of implementation. Maybe we can PM and you could point me in the direction if you don't mind?
Just copy the SSDT to ACPI folder under OC and update the config to load the SSDT.
<key>ACPI</key>
<dict>
<key>Add</key>
<array>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-EC-USBX-AMD.aml</string>
<key>Path</key>
<string>SSDT-EC-USBX-AMD.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-NVME.aml</string>
<key>Path</key>
<string>SSDT-NVME.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-PLUG.aml</string>
<key>Path</key>
<string>SSDT-PLUG.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-XHC.aml</string>
<key>Path</key>
<string>SSDT-XHC.aml</string>
</dict>
</array>
 
  • Like
Reactions: ravenas

ravenas

New member
May 6, 2020
12
1
3
Just copy the SSDT to ACPI folder under OC and update the config to load the SSDT.
<key>ACPI</key>
<dict>
<key>Add</key>
<array>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-EC-USBX-AMD.aml</string>
<key>Path</key>
<string>SSDT-EC-USBX-AMD.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-NVME.aml</string>
<key>Path</key>
<string>SSDT-NVME.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-PLUG.aml</string>
<key>Path</key>
<string>SSDT-PLUG.aml</string>
</dict>
<dict>
<key>Enabled</key>
<true/>
<key>Comment</key>
<string>SSDT-XHC.aml</string>
<key>Path</key>
<string>SSDT-XHC.aml</string>
</dict>
</array>

I'm not using NVME, but is SSDT-PLUG.aml required?
 

gopal334

New member
May 2, 2020
13
2
3
Ok well that SSDT did its job. Thanks for the support. Now if I could just get sleep working...
Good Luck. Let me know if Sleep Works. In my case If I don't have any USB devices connected (including keyboard, mouse) Sleep kinda works. If I try sleeping it will wake up immediately, retry makes it go to sleep. The Power is switched off. I can wake it up only by pressing the power button. Would love to hear back your experience with sleep.
 

ravenas

New member
May 6, 2020
12
1
3
Good Luck. Let me know if Sleep Works. In my case If I don't have any USB devices connected (including keyboard, mouse) Sleep kinda works. If I try sleeping it will wake up immediately, retry makes it go to sleep. The Power is switched off. I can wake it up only by pressing the power button. Would love to hear back your experience with sleep.
Mine is slightly different. Desktop sleeps and computer appears to go to sleep. The keyboard lights turn off and mouse lights turn off. Can't hear fans. The power led never starts blinking though. I can't wake the computer up unless I do a hard restart.
 

gopal334

New member
May 2, 2020
13
2
3
Intresting. Thanks for posting back. Would you be able to see if the behaviour changes without any USB devices? Try with BlueTooth Keyboard and mouse and see if it works any better?
 

ravenas

New member
May 6, 2020
12
1
3
Intresting. Thanks for posting back. Would you be able to see if the behaviour changes without any USB devices? Try with BlueTooth Keyboard and mouse and see if it works any better?
I will check for power light blinking with no USB devices attached. I currently do not have a Bluetooth keyboard/mouse.