Upgraded to Ryzen 5 5600X, now most of my ports don’t work.

[email protected]

OG Nerd
Donator
Joined
Dec 7, 2021
Messages
34
I upgraded one of my boxes from a 5 3600 to a 5600x on a Gigabyte X570 Gaming X board. Now most of my USB ports are dead in Mac OS and windows. Been reading that this was an issue but should not be now but it is. Updated to latest bios, tried disabling c states and nothing. Anyone else having these issues?
 

[email protected]

OG Nerd
Donator
Joined
Dec 7, 2021
Messages
34
No it even does it in windows, when using the usb map tool it shows that the USB ports are drawing too much power, to unplug something but nothing is plugged in. Googling it, it seems to be an issue with some x570 boards and 3rd gen ryzen s. AMD supposed to patch it late last year but people still having issues. I even made sure to update bios but still no go. Hate to switch back to my ryzen 3600 but might do so.
 

Bansaku

Member
Joined
May 3, 2020
Messages
52
No it even does it in windows, when using the usb map tool it shows that the USB ports are drawing too much power, to unplug something but nothing is plugged in. Googling it, it seems to be an issue with some x570 boards and 3rd gen ryzen s. AMD supposed to patch it late last year but people still having issues. I even made sure to update bios but still no go. Hate to switch back to my ryzen 3600 but might do so.

I'd double check your CPU seating, even look for any thermal paste that may have squeezed through the gap. Given the fact that the issue persists in Windows and all you did was switch the CPU, I'd start there. You may have a faulty chip or you messed up the installation; USB is controlled through the CPU.
 

Edhawk

Member
Joined
May 2, 2020
Messages
96
Changing your CPU will effect the USB ports, some of them anyway.

Your motherboard has the following USB controllers and ports.

Integrated in the CPU:
  1. 4 x USB 3.2 Gen 1 ports on the back panel
Chipset:
  1. 4 x USB 3.2 Gen 1 ports available through the internal USB headers
  2. 6 x USB 2.0/1.1 ports (2 ports on the back panel, 4 ports available through the internal USB headers)
The CPU controlled USB ports will have changed when you changed your CPU. The Chipset USB ports should be unaffected.

You need to reconfigure/recreate your USBMap.kext or USBPorts.kext to deal with this change of CPU.
 

[email protected]

OG Nerd
Donator
Joined
Dec 7, 2021
Messages
34
I am going to mess with it tomorrow. I am leaning towards issue with installation or CPU itself. I installed a water cooler, so possibly got some grease on a pin. I bought two of the 5600's and the one in the B550M board works great. I dont think it would be the usb map kext, I dont have one yet, didnt need with the 3600, but as soon as I installed the 5600x I lost half the ports on back panel, even in bios, it would show my external drives in the bios that were plugged into some of the ports, but no longer does. Odd issue for sure.
 
Top Bottom