Updating OC

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
Hi,

Im trying to update to the latest OC. Ive gone through the guide on how to do this, but cannot figure out what is stopping me booting from the USB. EFI attached, any help would be great.

Thanks
Rob
 

Attachments

  • EFI.zip
    1.8 MB · Views: 2

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
547
@r08ert0 Add your smbios details back and try now.
I noticed your USBMap.kext wasn't attached to your config.plist so I added it for you but as I don't know if its meant to be in use or not I left it disabled so enable if you want to use it.
 

Attachments

  • EFI.zip
    2 MB · Views: 2

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
@r08ert0 Add your smbios details back and try now.
I noticed your USBMap.kext wasn't attached to your config.plist so I added it for you but as I don't know if its meant to be in use or not I left it disabled so enable if you want to use it.
@AudioGod Thanks for the USB heads up. Still doesn't work. I just get a blank screen if booting from my USB. Ive tried again from scratch and still the same. Any ideas?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
547
@AudioGod Thanks for the USB heads up. Still doesn't work. I just get a blank screen if booting from my USB. Ive tried again from scratch and still the same. Any ideas?
do you have above 4g enabled in the bios?
If you do have it enabled then try disabling it and adding npci=0x2000 The boot arguments
also try clearing your nvram
 

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
do you have above 4g enabled in the bios?
If you do have it enabled then try disabling it and adding npci=0x2000 The boot arguments
also try clearing your nvram
Just tried all of that, still nothing. Stumped.
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
828
@r08ert0 I've remade the EFI from scratch. Not sure on your 4G setting so I've added npci=0x2000. Adjust accordingly and add your SMBios info back in.
 

Attachments

  • EFI.zip
    1.8 MB · Views: 1

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
@r08ert0 I've remade the EFI from scratch. Not sure on your 4G setting so I've added npci=0x2000. Adjust accordingly and add your SMBios info back in.
Hi @Shaneee , thank you for taking the time to do this. My 4g setting is enabled, so do I remove npci=0x2000? Im running Catalina 15.7. Do I need to name the USB as EFI or is it OK just to have the EFI on the USB named anything?

This is what comes back in Sanity Checker.

 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
828
Yes if you’ve got 4G enabled remove the npci boot arg. No need to rename the drive just mount the efi partition and place the efi folder inside.
The sanity checker needs an update.
 

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
Yes if you’ve got 4G enabled remove the npci boot arg. No need to rename the drive just mount the efi partition and place the efi folder inside.
The sanity checker needs an update.
The actual sanity checker website needs updating or the config does?
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
828
The website. It’s not been updated for the changes to OpenCore.
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
828
You don’t boot efi. It’s effectively loading itself that way. You need to choose the macOS option whether it’s the installer or an installed system.
 

r08ert0

Donator
Donator
Joined
May 6, 2020
Messages
19
You don’t boot efi. It’s effectively loading itself that way. You need to choose the macOS option whether it’s the installer or an installed system.
Ah ok. On my picker there is no Mac OS option. It’s an installed system and all I want to do is update OC. Do I need Mac OS on the USB?
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
828
Well that’s an issue. Replace VBoxHfs with OpenHfs included with opencore. Remember to alter the config to reflect this change.
 
Top Bottom