Unknown USB Controller (PTXH) + inconsistent USB behavior


New member
Aug 25, 2020
Hello AMD-OSX Forum,

My name is Erik Landi, I'm a long time follower of the forum and greatly appreciated all the help and guides that the community has provided over the years.

I've had my Ryzentosh working since the Catalina days and generally have been very impressed with stability outside of one glaring issue. My USB 3.1 GEN 2 controller has never appeared in hackintool correctly and I have some issues with USB peripherals on the ports connected to the controller. I have mapped the USB Ports following the manual port mapping method with the AMD-USB-MAP.kext edited with my configuration. I know the mapping has worked because my Bluetooth module is recognized out of sleep (I had mapped the internal USB 2.0 Header with type 255 and was reflected in hackintool). Sleep of course is working but in order to wake the machine out of sleep with USB, the Mouse and Keyboard must be plugged into XHC0 controller not PTXH. My USB dac and usb sound card also need to be plugged in and out in order to function again out of sleep though no matter what USB port those are in.

The issue is that my Logitech Brio Webcam refuses to work with ECAMM live or Skype or MS Teams. The enable light on the Camera turns on when an app access the camera but I will not get the video feed (video preview screen stays blank in apps). However, if I activate Facetime all of a sudden the video feed will work and I can see video output on both the app in questions and facetime app. It feels like it's some kind of enumeration bug and facetime is forcing the controller to reset itself somehow but that is just a guess. This behavior is seen in both the GEN2 USB-A and USB-C ports.

If I run the Camera under the XHC0 Controller the Camera runs without issue.

As you can see the Name of the controller is ??? and the other is labeled as it should be. I've also included my dumped raw DSDT just incase anyone wants to see where the PTXH controller lives. (IOACPIPlane:/_SB/[email protected]/[email protected]/[email protected])

HPET (Hibernation)
PLUG (Power nap enabled)
SBRG (system stability)
SBUS-MCHC (MAC os will kernel panic during streaming without this)
USBX (USB power fixes)

System Specs:
MOBO: MSIx470 Gaming Pro Carbon
MEM: 32GB Corsair LPX DDR-3200
MAC OS: 11.6.1
WIFI:Fenvi T919

Any thoughts or insights would be super appreciated. Just one note, I do have some developer experience writing drivers and code so don't be afraid to get into the weeds so to speak :)


  • EFI.zip
    9 MB · Views: 3
  • config.plist
    36.2 KB · Views: 0
  • DSDT.aml.zip
    12.6 KB · Views: 0
Top Bottom