Unconsistent stability issues

misterrm

New member
Joined
Oct 27, 2021
Messages
28
Hello Guys,

So i am using my Ryzentosh for last 1 year, currently at Monterey 12.4 with below specification. I am struggling with weird issue that happens sometimes.

I use my Hackintosh for web usage mostly. I have only few applications on it, i think this issue might be safari related but i am not sure.

I can literally run my hackintosh for hours or day and everything works without even single hiccup, i can watch netflix, youtube, scroll facebook without any issues, but sometimes loading some media's on mentioned sites is causing safari to hang all the media related activities going on all tabs (So for example i am watching something on youtube, then i try to play something on different tab and it causes issues on both of them)

Sometimes it seems to "restart" the medias and it just recovers at its own, but sometimes it is causing system unresponsiveness, like the whole OS is hanging out for few seconds, all i can do is move the mouse cursor, but none of apps or bars are "clickable". Then it will unhang for few seconds, then it starts again. Sometimes "loading" cursor is showing.

I know that i cant expect 100% stability on poor hackintosh but i really wish i could track this issue as its driving me crazy.

Do you know any methods or software that could help me investigate whats going on with the system calls / hardware in the background?

My hardware is 100% healthy, i doubt this is hardware related issue

Spec:
CPU: Ryzen 3900x
MOBO: Aorus X570
RAM: 32GB 3600MHZ
SSD: 980 PRO 512GB
GPU: RX 580

Opencore: 0.7.9 + Monterey 12.4 (21F79)
 

Edhawk

Active member
Joined
May 2, 2020
Messages
686
If it is Safari related, as you suggested, have you thought of installing FireFox Mozilla browser and using that instead of Safari for your video watching.

There are a number of other Browsers you could use in macOS, not just Firefox.

If the issue persists when you are using another browser, you can then look at finding the root cause.
 

RyzeCooker

Donator
Donator
Joined
May 3, 2020
Messages
245
You can check Console to see if there was any weirdness around the time of the hiccups, or keep a tail -f /var/log/system.log open in a Terminal window to see if messages appear there. If you are using Chrome you could see if checking (or unchecking) 'Use hardware acceleration when available' makes any difference. I had pauses when acceleration was on, but that hasn't been an issue for a long time (it's always on in my setup these days)
 
Top Bottom