Super thanks from Finland

ryyzz

New member
Joined
Dec 4, 2021
Messages
6
Hi,

I have IT and computer architecture included in my degree but building PC's is a hobby. I was a Windows only user and fan until 2012 when I built a nwe PC to myself again.
Finding an article describing how to install OS X on an Intel PC made my curios just to see how well it works and it changed it all. I simply fell in love with OS X as an Operating
System (as you may know, Windows is not an Operating System, it is spaghetti code to make money to Bill). I have built some 5-6 Intel hackintoshes an collected a massive
amount of old Macs.
Last year 2020 I had to get a Ryzen 5 as my Windows games rig. It happened again, so I did find out the MacOS can be installed on Ryzen too and had to give it a try. And BOOM
it worked like a charm, with PCI 4.0 and lots of performance and was stable. In January I got my current AMD that works even smoother and it also activates with my Apple Watch
thanks to genuine Apple Wifi/BT card. I even managed to get my Titan-ridge thunderbolt 3 card, flashed for Mac Pro 5.1, to work (requires hot reboot to load drivers for Thunderbolt
gear) but now operates only on 20Gb speed and thunderbolt/ethernet does not work yet.

Now I try to enable Saphire RX 550 2GB PULSE on MacOS. I managed to get it to work including acc in Mojave and Big Sur when NOT using WEG (but all ports not working then).
I also need to get agdpmod=pikera into DeviceProperties so that it affect only my RX 6900 card, but have not yet found the right syntax, please send me should you know.

And last: A BIG THANKS TO SHANEEE AND ALL OTHERS MAKING HACKINTOSH AND RYZENTOSH POSSIBLE.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,799
Welcome :D
The RX 550 isn't a native card in macOS if it has the Lexa core. You can check this in GPU-Z on Windows. Although why do you have that card when you've got a 6900? WEG isn't required for that or at least it shouldn't be. I don't use it for my 6800 and have no issues.
 

ryyzz

New member
Joined
Dec 4, 2021
Messages
6
Last week I installed Windows 10 32bit as dual boot on my first hackintosh from 2012, a 4th gen Intel. I wanted to play old Windows 95 games natively and they work well even with Windows 10 but required 32 bit in order to have full support also for 16 bit apps. It had only iGPU and grabbed an Saphire Radeon RX 550 2GB Gaming from my shelf and was suprised there where no support for it for Windows 10 32bit, only 64bit. However, I took the latest 32bit driver pack and manually installed the most most closest driver, RX 455, that was within the 32bit install kit. To my suprise it installed and worked like a charm.
I have had a need to get a basic and silent adeon card for my Mac Pro 2010 at office with OpenCore Big Sur so I thought the RX 550 maybe could be spoofed to MacOS as well. First I tried with the old 4th gen Intel with Clover and Mojave and it worked well with an SSDT spoofing the RX 550 to 0x67EF. Next I wanted to try it with Big Sur or Monterey and did not want to wait getting to office but instead tried it on my AMD rig with Rx 6900 Xt and wanted also to learn how to manage two egpu's within OpenCore. It worked in AMD Montery well (without WEG), but only with the port I had attached at boot (no port without any dispaly at boot), so I thought Whatevergreen will fix the video ports, but the spoof did not work with WEG. Third step was I wanted to try putting the rx 550 device-id spoof within Opencore Deviceproperties instead, but the result was the same (no spoof).
On Sunday I did find out that I have to disable the automatic spoof built into Whatevergreen in order to make a selfdefined spoof, so I added "no-gfx-spoof = <01 00 00 00>" and it works great now in my AMD, 4th gen intel and my Mac Pro 2010 at office. The HDMI (and Displayport) sound kind of works but is very distorted, and I want to still fix this too.
Is this something new that we can get RX 550 Lexa based to work in OpenCore? I can make a publication of this if this is the case.
Please find screen shot from my AMD rig with a 4K + LG wide 5120x2160 combination with RX 550, full 30 bit colors + HDR + 60 Hz.

 

Attachments

  • Saphire RX 550 2GB Gaming MacOS 12.0.1.jpg
    Saphire RX 550 2GB Gaming MacOS 12.0.1.jpg
    541 KB · Views: 1
  • RX 550 on 5K AMD r9 Monterey 12.0.1.png
    RX 550 on 5K AMD r9 Monterey 12.0.1.png
    3.6 MB · Views: 1
Top Bottom