SUCESS GIGABYTE TRX40 AORUS PRO WIFI (rev. 1.0) Threadripper 3960X

mSedek

New member
Joined
May 27, 2020
Messages
1
Hello, I got my GIGABYTE TRX40 AORUS PRO WIFI and threadripper 3960X with radeon 5700XT working perfeclty but I can't reboot or shutdown unless I hard press the power button for several seconds..

been reading and can't find anything related, I followed dortanias guide step by step for trx40 and generated SSDT this way

step 1-Dump DSDT
step 2-FakeEC
step 3-USB Reset

took only:
SSDT-EC.aml
SSDT-USB-Reset.aml

to the ACPI folder .. I don't know how else to solve the issue.

another issue is I have 4x 16GB memory modules and the SMBIOS generated was macpro7 and keeps telling me at login that the max memory supported blah blah , should I change the SMBIIOS fon an iMac 2017?

thanks in advance
 

maranz

New member
Joined
Dec 6, 2020
Messages
4
Hello, I got my GIGABYTE TRX40 AORUS PRO WIFI and threadripper 3960X with radeon 5700XT working perfeclty but I can't reboot or shutdown unless I hard press the power button for several seconds..

been reading and can't find anything related, I followed dortanias guide step by step for trx40 and generated SSDT this way

step 1-Dump DSDT
step 2-FakeEC
step 3-USB Reset

took only:
SSDT-EC.aml
SSDT-USB-Reset.aml

to the ACPI folder .. I don't know how else to solve the issue.

another issue is I have 4x 16GB memory modules and the SMBIOS generated was macpro7 and keeps telling me at login that the max memory supported blah blah , should I change the SMBIIOS fon an iMac 2017?

thanks in advance
Well, mine is 8x8GB on an iMac 2017 and I don't get any error msgs. Might be worth a try....
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,217
Hello, I got my GIGABYTE TRX40 AORUS PRO WIFI and threadripper 3960X with radeon 5700XT working perfeclty but I can't reboot or shutdown unless I hard press the power button for several seconds..

been reading and can't find anything related, I followed dortanias guide step by step for trx40 and generated SSDT this way

step 1-Dump DSDT
step 2-FakeEC
step 3-USB Reset

took only:
SSDT-EC.aml
SSDT-USB-Reset.aml

to the ACPI folder .. I don't know how else to solve the issue.

another issue is I have 4x 16GB memory modules and the SMBIOS generated was macpro7 and keeps telling me at login that the max memory supported blah blah , should I change the SMBIIOS fon an iMac 2017?

thanks in advance
You need to Map your USB if you haven’t already plus you are missing SSDT-USBX.aml
Memory errors due to 7,1 are purely cosmetic but you have two options to correct the error message.
1. Use the restrictevents.Kext
2. Map your memory.


By the look of it to me you have not read though the OC guide properly and skipped past many parts of it that hold all the answers to your problems.
 
Top Bottom