[successful] B450 Pro Carbon AC Problem Bluetooth BCM94360CD (T919)

sharklatan

New member
Original poster
Nov 29, 2020
3
0
1
app.sharklatan.com
successful

update
luckily I solved them, and keeping the rgb
just disable with hackintool PRT4 (Bluetooth onboard)
place the generated files in their respective folders + remap usb and use kext 👇🏽 it works

Releases · acidanthera/BrcmPatchRAM

Contribute to acidanthera/BrcmPatchRAM development by creating an account on GitHub.
github.com

BrcmBluetoothInjector.kext

BrcmFirmwareData.kext

BrcmPatchRAM2.kext


I have used my EFI just added the changes

it also does not disable wifi onboard when deactivating it I lost the ethernet and I use it, all the usb ports working





Hello greetings to all I hope you are well

First of all he mentioned the BUILD descriptions

Installed Virtually all vanilla

Specs 👇

MOBO MSI B450 Pro Carbon AC
CPU Ryzen 5 2600x
Cooler AMD Wraith Prism RGB
GPU RX 580
RAM 8gb x 2 XGP GAMMIX D10
WIFI FENVI T919 BCM94360CD



I have problems with bluetooth, Which is apparently causing conflict with the onboard

The strange thing is that it worked for me the first time I connected the pci dapter (It worked natively and as expected)

This is the last part that I have left to be able to have it fully functional o_O

FENVI T919 BCM94360CD
It has no Hardware problem, it was tested on my Win 10 dualboot and it works perfectly

1606712286604.png

Then reboot and it didn't work again
I have tried to remap USB, But without success


OnBoard Bluetooth use USB Port PTR4
BRCM20702 Hub use USB Port PO14 / PO9 (I already tried to change the cable to another usb Connection )



I have already tried:
Remove the wireless card onboard (
Disable USB ports PTR4, PTR3, PTR5 etc

But I still don't get this to work properly (I just learned how to perform and not very well)


I've already run out of ideas and what else to do:cry:
I hope someone can help me solve this problem


EFI FOLDER


Attached capture of:


IOREGISTRYEXPLORER

1606712723916.png

HACKINTOOL
1606712909480.png

SYSTEM INFO
1606713344572.png

1606713355945.png



1606713362724.png





Thanks in advance I hope someone can help me
 
Last edited:

sharklatan

New member
Original poster
Nov 29, 2020
3
0
1
app.sharklatan.com
UPDATE

I have used the following guide

Removing the XHC0 controller with killXHC0.kext

Now the device looks like this

1606780983465.png1606781027549.png

But I still can't get the bluetooth to work or be recognized


As I had already commented on the PTR4 port It is the one that controls the internal bluetooth
I have also disabled the wi-fi card from the bios

Now it tells me as if a Bluetooth device were not present
1606781206836.png

The USB dongle T919 (BRCM20702 Hub) is connected to the PO14 port

1606781345331.png

I still can't find How to make it work


It is the only thing that I still do not understand.
How is it that the first time I connected it, it worked and now it doesn't

Already tried to remapping, But I think I don't understand it much or I don't do it the right way
 

sharklatan

New member
Original poster
Nov 29, 2020
3
0
1
app.sharklatan.com
luckily I solved them, and keeping the rgb
just disable with hackintool PRT4 (Bluetooth onboard)
place the generated files in their respective folders + remap usb and use kext 👇🏽 it works


BrcmBluetoothInjector.kext

BrcmFirmwareData.kext

BrcmPatchRAM2.kext


I have used my EFI just added the changes

it also does not disable wifi onboard when deactivating it I lost the ethernet and I use it, all the usb ports working