[SUCCESS] agent2's Ryzen 9 3900X, ASUS ROG CROSSHAIR VIII Formula, AMD RX 6900XT, OC 0.6.9., macOS 11.4 Beta 3

agent2

Donator
Donator
Joined
May 3, 2020
Messages
140
My build:


- CPU: AMD Ryzen 9 3900X

- Motherboard: ASUS ROG Crosshair VIII Formula

- GPU: PowerColor Radeon RX 5700XT Red Devil (Farewell, old friend) - AMD Reference RX 6900XT

- RAM: 2*16GB 3200MHz 14-14-14-34 G.Skill Trident Z Royal Silver

- SSD: 2TB Gigabyte Aorus Gen 4

- CPU Cooler: Corsair H115i RGB Platinum

- PSU: Corsair AX850

- Case: Corsair Crystal 680X


OpenCore V0.5.9 - 0.6.1 - 0.6.9


All of it running on macOS 10.15.6 - 10.15.7 - 11.4 Beta 3


SMBIOS: MacPro7,1

I'm running all of this on a triple boot system with Manjaro Linux and Windows 10 Pro, which drive has which OS can be found in my signature. It all shows up in Opencore and is nicely configured with the nice OpenCanopy UI.

Kexts used:
  • AMDRyzenCPUPowerManagement.kext
  • AppleALC.kext
  • IntelBluetoothFirmware.kext
  • IntelBluetoothInjector.kext
  • itlwmx.kext - Switched to AirportItlwm.kext since using 0.6.1
  • Lilu.kext
  • MacProMemoryNotificationDisabler.kext, broken on Big Sur, going to switch to the alternative found in the Post-Install Guide.
  • RestrictEvents.kext - this fixed the memory configuration issue, but the CPU naming problem exists, will need to do some more tweaks for that
  • SmallTreeIntel82576.kext
  • SMCAMDProcessor.kext
  • VirtualSMC.kext
  • WhateverGreen.kext
  • NVMeFix.kext (using since 0.6.9)
  • CtlnaAHCIPort.kext (using since 0.6.9 and Big Sur)

What works:
  • Intel Wi-Fi (yes it does, but only on the 2,4GHz/5GHz bands @ 20MHz, which is slow) - Been using AirportItlwm disabled since 0.6.1, because it was all over the place in terms of connecting reliably to my Wi-Fi. Now on 0.6.9 and macOS 11.4 and the newest version of the kext, which has matured A LOT since then it works nearly flawlessly, I am always on the 5GHz band @ 40MHz, which is awesome! But sometimes on startup the Wi-Fi is disabled by default and I have to select my network manually even though I’ve set it to connect automatically. Good work OpenIntelWireless team!
Use Heliport app to manage (find on GitHub where itlwmx kext is)
  • Intel Bluetooth works and is manageable via the IntelBluetoothInjector.kext.
  • Handoff! It does actually work.
  • My internal NVMe SSD shows up as external but got it to work via the little config.plist tweak that was posted on Reddit, no silly kext needed
  • iServices (across the board, it’s no problem for now)
  • My Logitech peripherals (as they should with the corresponding drivers): G502 Lightspeed & G513 Carbon (Romer-G Tactile)
  • Maxon's Cinebench R23 is working just fine with the workaround app provided by Shaneee
  • Full GPU acceleration and DRM like AppleTV+, I know this might be unnecessary, but for people experimenting with RDNA2 GPUs it might be useful for now.
  • Optical audio works because macOS sets it to maximum volume at default and as long as the speaker setup you're using has it's own volume control, you're good!
  • The RX 6900XT usage chart shows up in activity monitor, this wasn't possible before on my 5700XT and in previous versions of OpenCore.

What doesn’t work:
  • Aquantia AQC111C 5Gbit Ethernet NIC, which pisses me off as I bought this board for the shit-ton of USB ports and the fast networking, I have asked the AMD-OSX gurus multiple times for a fix but no answer until now.
  • Optical audio is set default at maximum volume (not changeable, maybe change alcid) - This is not really a big problem, see above how I got it to work.
  • Handoff, AirDrop, Sidecar, all the cool shit the Broadcom cards can do on macOS
  • When I connect my headphones (front panel) to the PC, the internal speaker volume control vanishes, like what happens on iMacs. I find it really annoying and need to change the alcid to hopefully fix that (Will report on this once I've fixed audio for good via the Post-Install Guide)
  • The cool Aura control app Aureal isn't recognising my controller, do I need to USB map before it picks it up?
  • macOS doesn't see my 1TB Linux partition which is on the same SSD is this normal or what? I don't need to read any files from Linux but it seems strange that my Windows SSD and my Time Machine are recognised, but Linux is totally ignored. Is this because of a completely different way that it's formatted?

Work in progress:
  • Sleep (need to follow the guide)
  • USB mapping (Front 2x Type A are 3.0 but show up as 2.0; Rear USB 3.0 controller doesn’t show up at all)
  • I still need to manually create my SSDT-EC-USBX.aml because I’m still living off the stock SSDT-EC-USBX.aml
  • This might not be a complete problem, but my Logitech Streamcam has had the issue in the past where it after a while of using it the audio gets garbled and it emits the same sound recorded in the last second over and over. I thought it was because of the Logi Capture software for macOS still being in beta at the time but when that was a full release I wasn't sure if it was solved. I suspect it also might be a USB mapping issue, as the webcam is plugged into my front Type-C port.
  • A different audio problem has been mine to solve where my Corsair Virtuoso Wireless SE headset has been useless when in wireless mode. I've been able to listen to music when connected to the USB dongle, but the audio completely fails when switching the microphone on and enabling this in System Preferences. BUT when I plug the USB cable in and do audio via USB the microphone works, but only when activating the mic on the headset before switching to it in System Preferences. But when using FaceTime or Zoom or Signal with it it's a hit or miss getting the audio and mic working simultaneously over the USB cable. Sorry for the rant about this it's been a real pain in the ass and I've used Linux for now to circumvent it. I don't know if it's iCUE acting up or if it's weird Hackintoshy shit that's making this weird. I hope someone can lead me to an answer to this, even if it's just USB mapping. I'll also have a look if any of these weird USB issues have been solved with OC0.6.9 and 11.4.
  • Oh and I need to set up my Windows SSD and Time Machine to be seen as internal drives and not as external storage

Please feel free to ask me any questions! I will update this post as I advance in the Hackintosh profession! Maybe I'll add some photos later as well...
 
Last edited:

t968rs

New member
Joined
Aug 26, 2020
Messages
3
I really want to create a build based around the Crosshair. It seems like it would be a hard one though, with all those separate port/hub controllers. Have you figured out the stuff that doesn't work? I am particularly interested in USB functionality and sleep.
 

agent2

Donator
Donator
Joined
May 3, 2020
Messages
140
I really want to create a build based around the Crosshair. It seems like it would be a hard one though, with all those separate port/hub controllers. Have you figured out the stuff that doesn't work? I am particularly interested in USB functionality and sleep.
Yeah I loved the Crosshair VIII series from the start because ASUS was the only AIB with so many USB ports and connectivity.
I think that some of my USB controllers aren’t being picked up by macOS because I still haven’t made my custom SSDT-EC-USBX.aml yet. But right now all my 10Gbit rear USB ports are being picked up and the front USB-A is only USB 2.0 for some reason.
To be honest I bought this board just for the stupid amount of features present (and the cool OLED diagnostic screen ;)). But you would be better off buying the Hero (if you preferred the ATX Crosshairs) because the 2,5Gbit LAN is compatible with macOS (via a kext) and the 5Gbit LAN doesn’t work at all in macOS (which I just didn’t foresee).
But otherwise I’ll write more as I improve the USB port situation and sleep. But I love that board and I only bought it because I wanted to get a Gigabyte X570 AORUS Xtreme Rev.1.1 for full Thunderbolt support. But as I was impatient and wasn’t able to get one I just got the Formula for like a 60€ discount from 595€. But I’m having fun and that’s really the point!
Cheers!
 
Last edited:

agent2

Donator
Donator
Joined
May 3, 2020
Messages
140
Or if you like, you can also buy the Formula and both of us can pester the brilliant Hackintosh minds behind the community to develop a kext for those Formula, Maximus XI Formula, Maximus XII Hero and this Prime X299-Deluxe owners! You can look around the forum and find the various attempts I’ve made to get support for that 5Gbit NIC. :) But as the saying goes: The more the merrier!
 

meteoro

New member
Joined
Sep 9, 2020
Messages
3
Hello @agent2 , how are you?

I found your post from search in google... i have same hardware config except for processor (3950x) and GPU (RX 580).

I remap USB, use NVMeFix, follow guide... but i need:

• Sleep fix
• Bluetooth with IntelBluetoothFirmware.kext not locate any device

Have you had any progress in making sleep work? How detect devices with this kext for Bluetooth?

Many, many thanks!
 

agent2

Donator
Donator
Joined
May 3, 2020
Messages
140
@meteoro Sorry for the late reply. I'm working on a couple of updates, I will post them once they're ready. I've done a lot since then.
 

meteoro

New member
Joined
Sep 9, 2020
Messages
3
@meteoro Would you put your setup in your signature please? That would be helpful.

Thanks @agent2 , i have update my signature with my setup.

Edit: I can locate from my cell phone the hack with bluetooth, but the hack not locate for example my JBL or other devices. Well... after a little time the connection is lost and don't connect anymore in cell phone anyway. :(

Today i change the profile of sound in config.plist, now all my outputs is working. Change wifi kext, downgrade, update... and bluetooth still not working... sleep lets me crazy (my monitor sleep, my keyboard and mouse... and after that the machine stop responding with all fan on and mouse and keyboard not respond any more).

After that i receive this error on boot:

Code:
panic(cpu 18 caller 0xffffff801a49092c): Sleep transition timed out after 180 seconds while calling power state change callbacks. Suspected bundle: com.apple.iokit.IOUSBHostFamily. Thread 0x89aa.
Failure code:: 0x00000048 00000014

Backtracing specified thread
Backtrace (CPU 18), Frame : Return Address
0xffffff8e40ca3900 : 0xffffff8019e41868 mach_kernel : _machine_switch_context + 0xc8
0xffffff8e25d03990 : 0xffffff8019d3c4d1 mach_kernel : _thread_unstop + 0x1731
0xffffff8e25d03a00 : 0xffffff8019d3ad0f mach_kernel : _thread_block_reason + 0xaf
0xffffff8e25d03a50 : 0xffffff8019d2bb23 mach_kernel : _lck_mtx_sleep_deadline + 0x73
0xffffff8e25d03a90 : 0xffffff801a42bfef mach_kernel : __ZN10IOWorkLoop9sleepGateEPvyj + 0xbf
0xffffff8e25d03ad0 : 0xffffff801a42d103 mach_kernel : __ZN13IOEventSource9sleepGateEPvyj + 0x53
0xffffff8e25d03b10 : 0xffffff7f9a7f9a36 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController20lowerOnePowerStateToEm + 0x114
0xffffff8e25d03c80 : 0xffffff7f9d3b9890 com.apple.driver.usb.AppleUSBXHCI : __ZN12AppleUSBXHCI20lowerOnePowerStateToEm + 0x2e2
0xffffff8e25d03cf0 : 0xffffff7f9d663bc4 com.apple.driver.usb.AppleUSBXHCIPCI : __ZN15AppleUSBXHCIPCI20lowerOnePowerStateToEm + 0x1fc
0xffffff8e25d03d40 : 0xffffff7f9a7f8835 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController18setPowerStateGatedEmP9IOService + 0x2df
0xffffff8e25d03da0 : 0xffffff801a42e9d8 mach_kernel : __ZN13IOCommandGate9runActionEPFiP8OSObjectPvS2_S2_S2_ES2_S2_S2_S2_ + 0x138
0xffffff8e25d03e00 : 0xffffff7f9a7f8505 com.apple.iokit.IOUSBHostFamily : __ZN22AppleUSBHostController13setPowerStateEmP9IOService + 0xcf
0xffffff8e25d03e30 : 0xffffff801a413794 mach_kernel : __ZN9IOService19driverSetPowerStateEv + 0x184
0xffffff8e25d03ea0 : 0xffffff801a41359a mach_kernel : __ZN9IOService15pmDriverCalloutEPS_ + 0x2a
0xffffff8e25d03ec0 : 0xffffff8019d5c605 mach_kernel : _thread_call_delayed_timer + 0xec5
0xffffff8e25d03f40 : 0xffffff8019d5c131 mach_kernel : _thread_call_delayed_timer + 0x9f1
0xffffff8e25d03fa0 : 0xffffff8019cc013e mach_kernel : _call_continuation + 0x2e
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBHostFamily(1.2)[80AD6206-0EDB-39B5-A7B9-8FEAFD6407F3]@0xffffff7f9a7e4000->0xffffff7f9a8ddfff
            dependency: com.apple.driver.AppleBusPowerController(1.0)[D84ABB82-6590-3A4D-BF03-8AB990F2AF71]@0xffffff7f9a7ca000
            dependency: com.apple.driver.AppleUSBHostMergeProperties(1.2)[7D9D2E98-5B93-3287-89FB-16CBD09E351A]@0xffffff7f9a7d2000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[B5515CE4-E548-3AEE-9980-1967FB191C23]@0xffffff7f9a7d6000
         com.apple.driver.usb.AppleUSBXHCI(1.2)[D877721D-A4F1-3271-B4E2-C3668D189793]@0xffffff7f9d3a5000->0xffffff7f9d3fcfff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[2956198D-24F2-3790-A9B2-1EAB9434B906]@0xffffff7f9a709000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[80AD6206-0EDB-39B5-A7B9-8FEAFD6407F3]@0xffffff7f9a7e4000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[B5515CE4-E548-3AEE-9980-1967FB191C23]@0xffffff7f9a7d6000
         com.apple.driver.usb.AppleUSBXHCIPCI(1.2)[D5238DED-D891-3BED-A4B2-8FF9E58629DC]@0xffffff7f9d65b000->0xffffff7f9d68ffff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[2956198D-24F2-3790-A9B2-1EAB9434B906]@0xffffff7f9a709000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[44472E6F-8DA0-3B46-ADEF-AFF76EC6C6DB]@0xffffff7f9a712000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[80AD6206-0EDB-39B5-A7B9-8FEAFD6407F3]@0xffffff7f9a7e4000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[B5515CE4-E548-3AEE-9980-1967FB191C23]@0xffffff7f9a7d6000
            dependency: com.apple.driver.usb.AppleUSBXHCI(1.2)[D877721D-A4F1-3271-B4E2-C3668D189793]@0xffffff7f9d3a5000

BSD process name corresponding to current thread: kernel_task
Boot args: keepsyms=1 npci=0x2000 darkwake=2 chunklist-security-epoch=0 -chunklist-no-rev2-dev

Mac OS version:
19H2

Kernel version:
Darwin Kernel Version 19.6.0: Mon Aug 31 22:12:52 PDT 2020; root:xnu-6153.141.2~1/RELEASE_X86_64
Kernel UUID: 05D51A3D-3A87-3FF0-98C3-9CF3827A3EDD
Kernel slide:     0x0000000019a00000
Kernel text base: 0xffffff8019c00000
__HIB  text base: 0xffffff8019b00000
System model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 4009108105522
 

agent2

Donator
Donator
Joined
May 3, 2020
Messages
140
UPDATE:

Hello everybody at AMD OS X, old and new,

it's been a while since I've been active on this forum, university work hasn't been kind to my Hackintoshing ambitions.
I hope everybody is fine and safe, it's been one hell of a year to have lived through.
I'm writing this update with new hardware and a "boatload" of information I have accumulated during my Hackintosh tenure.

The last few months (since October actually) I've been running on OC 0.6.1 and macOS Catalina 10.15.6/7. I'd been running an alpha version of AirportItlwm and that virtually didn't ever give me a steady Wi-Fi connection after I'd upgraded from itlwmx/Heliport, which gave me an abysmal 20MHz on each band, which was at least stable. But I suspect those were early adopter issues as I was one of the early group to try it out instead of getting a Broadcom card.
I had given up on updating to new versions of OpenCore because for some reason after formatting the USB in Linux and setting up the EFI, after booting into macOS with it the files in the EFI on the USB would be corrupted and I would find it useless to copy that into my boot drive‘s EFI. This happened so many times I got fed up with it and didn’t bother any further. So I used the OC0.6.1 without OpenCanopy (that also broke my bootloader for some reason even though I had it working with OC0.5.9, these stupid issues just accumulated) and macOS 10.15.6 and then 10.15.7.

Oh and when I once tried to install Windows 10 Pro on my other SATA SSD I had dug out from elsewhere, I messed up OpenCore and GRUB completely due to Microsoft‘s stupid way of selecting which drive to install Windows on.
So I took the measure of reinstalling OC and removed my NVMe SSD altogether from my system and only had the SATA SSD plugged in to clean install Windows. That went all fine and dandy until I screwed my NVMe SSD back into my motherboard and wanted to boot macOS. That move for some dumb reason wiped OpenCore out of my BIOS selector. So here we go again: Remake an OC USB from scratch.

All of that was so much of a headache I decided to give my Computer a rest and I kinda had enough of tinkering with it. That’s just putting it short 😅.

So some time goes by and I am looking forward to upgrading my OpenCore because I hadn‘t done it in a while and with the new release coming out, I saw the report that the Navi 21 finally has full macOS support in the newest beta.
That news alone got me pretty excited to get back to Hackintoshing and upgrading OC to get to Big Sur.
And as luck would have it, end of April I was able to snag an RX 6900XT from AMD‘s drop at MSRP, that was a call from Hackintosh heaven 😇 To get my ass up and running.

So updating to 0.6.9 with all the new kexts and without the help of the OC sanity checker (which only goes to 0.6.6), it went nearly flawlessly. I was surprised how well the update went. I of course made it from a fresh USB and added everything one by one, as to not make any unnecessary mistakes.
But with that done, my next step was to update to Big Sur. Whilst reading the Dortania OC Guide about Big Sur I became really worried with my OC version if it was just as easy to hit “update” or if any of the dreaded problems would arise for me, especially because of my inexperience or my weird triple boot system.
I therefore added the CtlnaAHCIPort.kext with the worry that macOS 11 would break everything. I also was worried if the boot args for RDNA1 cards would also apply to RDNA2 cards, especially as there’s no mention of them in the official guide.

But I hit the update button anyway and away my PC chugs, and half an hour later, I have Big Sur 11.3.1 running buttery smooth! Wi-Fi works a charm and I couldn’t complain about a thing!
So after enrolling my PC in the Beta program, I get the installation of the beta underway and after that worked it’s magic, here I am!
The Beta runs without a flaw, I haven’t noticed any problems whatsoever on the software side of things, my 6900XT works a charm and I’m relieved to have everything stable and functional! (I sold my 5700XT Red Devil though, it served me well)

And of course I couldn’t have done it without the awesome community here which I have found to be brilliant and the useful and detailed Install guide.

But that’s enough talk for now, I’ve rambled on enough about my adventures. In the original post you’ll find all the tweaks I’ve made to my system now and more problems and observations I’ve seen and encountered.

Cheers everybody! More to follow!
 
Last edited:

flames

New member
Joined
Sep 2, 2020
Messages
1
@agent2, Great News!
I didn't updated my Hackintosh from old i7 3930k + gigabyte x79s-up5 + rx580 for years, just had to time.
But then I built a new Windows workstation with the Crosshair Viii Formula, Ryzen5950x and 6900xt gpu (which was not supported)... as soon as 11.4 beta came out, it took only few hours to make Big Sur running perfectly. An it is really running perfectly, smooth, wow.
Disabled onboard Wifi, BT and 5GbE, because they don't work anyway as expected. For handoff and other features put my old bcm94360cd.
Only thing left to do, is configuring the USB ports. All Ports (internal and external) are working. One of the USB3-front conenctors is running only in 2.0/high speed mode.
Machine is stable and powerful like a dream!
Also from me huge THANKS to this community and all the information and development!
 
Top Bottom