Some of the waves plugins are crashing [Logic Pro X]

rohan

New member
Joined
May 14, 2020
Messages
15
Hi @shaane,
well I basically use hackintosh for music production..
Waves is a additional plugin library for Logic Pro x

some of the waves plugins crashes as soon as they are validated here is the crash report of one of the plugin "z-noise"

here is the crash log :- https://pastebin.com/Sa3a2hU9

can u pls let me know how do I fix this?

This happens on high Sierra, Mojave and Catalina
 
Last edited:

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,293
The application is looking for _intel_fast_memset which we can't provide on AMD.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,293
I don't see a specific error there. Did the plugin still crash?
 

0rca

New member
Joined
May 30, 2020
Messages
5
@rohan
I also built a hackintosh for music production... unfortunately I'm getting the same problem with many of the waves plugins. The ones that don't work don't work for AU, VST, or VST3. I'm not even 1/8 of the way done installing my VST collection... and I fear I may have made a mistake on going with AMD.

Have you run into any other issues with any other VSTs?

I had to go with Catalina, my graphics card requires it. So I was prepared that a lot of my 32-bit apps wouldn't work. (planned to install Mojave, but alas... didn't realize Navi was unsupported)

Ableton Live 10 is working decently, otherwise... Not quite snappy as I would expect on a 3700x. CPU meter seems to light up faster than I'd think. Need to do more testing obviously... but I wonder if maybe it's time to throw it in and just transition to Windows. I just really don't want to...
 

danny

New member
Joined
May 10, 2020
Messages
16
Sorry shanee I'd be interested in this too
VPS avenger doesn't work for me, i think it needs some sort of Intel something
Nexus 32 bit doesn't work using 32 lives and id like to know if there is any way in the world to make it work
Waves plugins can't install from installer (latest version) it says to contact the developer because i noticed main drive is not recognized
If u could help would be awesome thanks a lot
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,293
Which plugin in particular though? Or is there a way for me to replicate the crash without a plugin?
 

danny

New member
Joined
May 10, 2020
Messages
16
Oh I'm sorry, they crash when they are being evaluated by Logic Pro X for me. Avenger says something like intel fast memset crashed and can't use the plugin (just asking if there is a workaround or something), 32 lives works only with 32 bites so if there is any way to enable it on Mojave 10.14.6
Waves gives me this everytime, after downloaded their utility for installing their plugins, can't install them nor legit, nor cracked
I tried with an intel hack and works without a problem. If u have some ideas, thanks a lot
 

Attachments

  • Schermata 2020-06-04 alle 18.16.25.png
    Schermata 2020-06-04 alle 18.16.25.png
    7.6 KB · Views: 34

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,293
Try launching Logic Pro X from Terminal with this command,

Code:
MKL_DEBUG_CPU_TYPE=5 /Applications/Logic\ Pro\ X.app/Contents/MacOS/Logic\ Pro\ X
 

danny

New member
Joined
May 10, 2020
Messages
16
First, thanks a lot for the code! It worked on every Waves plugin that couldn't be evaluated before so really thanks :) Unfortunately Vps Avenger doesn't work anyway, I don't understand why. This is the error with the official installer from the site
 

Attachments

  • Schermata 2020-06-06 alle 01.02.14.png
    Schermata 2020-06-06 alle 01.02.14.png
    45.4 KB · Views: 30

danny

New member
Joined
May 10, 2020
Messages
16
I tried it also on my Nexus AU created with 32lives (a software to bridge plugins from 32 to 64 plugins) I got this error. Do you have any clues? anything I could do
 

Attachments

  • Schermata 2020-06-06 alle 01.02.49.png
    Schermata 2020-06-06 alle 01.02.49.png
    57 KB · Views: 27

danny

New member
Joined
May 10, 2020
Messages
16
On Vps Avenger there is also this
 

Attachments

  • Schermata 2020-06-06 alle 01.14.17.png
    Schermata 2020-06-06 alle 01.14.17.png
    147.9 KB · Views: 20

djmartain

Member
Joined
Jun 2, 2020
Messages
30
Try launching Logic Pro X from Terminal with this command,

Code:
MKL_DEBUG_CPU_TYPE=5 /Applications/Logic\ Pro\ X.app/Contents/MacOS/Logic\ Pro\ X
Does this also work for Ableton? I'm in the same boat as i'm about to install waves and stumbled on this topic :)
 

danny

New member
Joined
May 10, 2020
Messages
16
Does this also work for Ableton? I'm in the same boat as i'm about to install waves and stumbled on this topic :)
It should work if they are AU, try changing the string with Ableton directory inside Ableton pckg; instead of logic one.
Problem with Waves on AMD hack is that waves central doesn't recognize main drive and you get stuck to "please restart or contact support", you can still install V10 tho
 
Top Bottom