[SOLVED] Cinema 4D R22 and R23 Fail to load


May 4, 2020
Wondering if anyone else is experiencing this problem where R22 will begin loading, but stick on "initalizing layout" forever. And R23 just crashes outright. Guessing there may be an Intel library it's looking for or something? Here's a shortened crash report.

UPDATE: I replaced the /Applications/Maxon Cinema 4D R23/corelibs/../resource/modules/denoiser.module/libs/osx/libOpenImageDenoise.dylib
with the R21 version of the Denoise Library and now it boots to "Initalizing Layout" but then locks up.

UPDATE 2: So it looks like the best thing to do is delete the entire application and preferences (~/Library/Preferences/Maxon/Maxon Cinema 4D R23_#######)
Reinstall and then before opening it, delete all the denoiser files.

It's an intel denoiser, so copying the previous versions in there probably wouldn't work anyway.

Boom! Now it works.

Process:               Cinema 4D [2240]
Path:                  /Applications/Maxon Cinema 4D R23/Cinema 4D.app/Contents/MacOS/Cinema 4D
Identifier:            net.maxon.cinema4d
Version:               23.0 (323902)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cinema 4D [2240]
User ID:               501

Date/Time:             2020-10-22 15:50:06.982 -0400
OS Version:            Mac OS X 10.15.6 (19G2021)
Report Version:        12
Anonymous UUID:        #########

Time Awake Since Boot: 1900 seconds

System Integrity Protection: disabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x00007ffedfa77ff8
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [2240]

VM Regions Near 0x7ffedfa77ff8:
    MALLOC_MEDIUM (reserve 00007fcd28800000-00007fcd30000000 [120.0M] rw-/rwx SM=NUL  reserved VM address space (unallocated)
--> STACK GUARD            00007ffedc278000-00007ffedfa78000 [ 56.0M] ---/rwx SM=NUL  stack guard for thread 0
    Stack                  00007ffedfa78000-00007ffee0278000 [ 8192K] rw-/rwx SM=ALI  thread 0

Application Specific Information:
/Applications/Maxon Cinema 4D R23/corelibs/../resource/modules/denoiser.module/libs/osx/libOpenImageDenoise.dylib
Last edited:


New member
Nov 1, 2020
Sorry but it doesn't work for me for R23... it still remains in the layout loading page... any other clue?
Last edited:


The AMD Guy
Staff member
Mar 13, 2020
Just gets stuck here then crashes after removing those files.

Must've been a bad install. Working just fine now,

Screenshot 2020-11-03 at 11.51.10.png
Last edited:


New member
Nov 20, 2020
Sorry but it doesn't work for me for R23... it still remains in the layout loading page... any other clue?
Hi there ,, I had some issue But it solved ,, Just uninstall r23 and install again, don't delete anything and not use crack file. After installation finished just start C4D. Licensing screen will appear, Walt here just few second to be sure it fully loaded, than just close it , do this step maybe for two times more and than crack the software and open it, it should be working...
Top Bottom