Shaneee's ASUS ROG STRIX X570-F GAMING - OpenCore 0.7.4 EFI

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295

Shaneee's ASUS ROG Strix X570-F GAMING - OpenCore 0.7.4 EFI​

For macOS Big Sur 11.x and macOS Monterey 12.x​


System Specs:IMG_5072.jpeg

BIOS Settings:​

  • Enter BIOS -> Press Delete -> Enter Setup​
  • Exit -> Load Optimised Defaults​
  • Ai Tweaker -> Ai Overclock Tuner -> D.O.C.P.​
  • Advanced -> APM Configuration -> Power On By PCIe -> Disabled​
  • Advanced -> PCI Subsystem Settings -> Above 4G Decoding -> Enabled​
  • Advanced -> PCI Subsystem Settings -> Re-Size BAR Support -> Disabled​
  • Advanced -> USB Configuration -> Legacy USB Support -> Auto or Disabled​
  • Boot -> Boot Configuration -> Fast boot -> Disabled​
  • Boot -> CSM -> Launch CSM -> Disabled​
  • Boot -> Secure boot -> OS Type -> Windows UEFI mode​
  • Boot -> Secure boot -> Key Management -> Clear Secure Boot Keys​
BIOS Settings thanks to AudioGod's X570-E topic.

Install Notes:

There are a few changes you'll need to make to the EFI before you can boot with it.

First of all open up the config.plist file in a Plist editor like PlistEdit Pro, Xcode or ProperTree. Navigate to PlatformInfo -> Generic and add the required SMBios details.
  • MLB
  • ROM
  • SystemSerialNumber
  • SystemUUID
You can use GenSMBios from CorpNewt to generate these values. Get the app here, https://github.com/corpnewt/GenSMBIOS

CoreCount Patch:
The Core Count patch needs to be modified to boot your system. It's currently setup for a 6 Core CPU. A detailed explanation on how to edit this can be found here, https://forum.amd-osx.com/index.php?threads/new-amd-macos-corecount-patch-information.1948/

NVRAM: When you first boot with this EFI, Once at the OpenCore Boot Picker, press the spacebar and Reset NVRAM. The system will reboot and take you back into OpenCore.

GPU: If you are using a RX 6800 or any other Navi or Big Navi GPU then add agdpmod=ignore to the boot arguments.

Note: The SmallTreeIntel82576.kext is not working under Monterey 12.x so if you plan on playing around with the new OS for now make sure you have another network device such as WiFi that is supported.


Changelog:
06/09/21
  • Updated OpenCore to 0.7.3
  • Added OpenLinuxBoot for Linux Dual Booting
05/10/21
 

Attachments

  • Shaneee_X570-F_0.7.3.zip
    4.1 MB · Views: 131
Last edited:

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295

OpenCore 0.7.4 EFI Update​

Updated to OpenCore 0.7.4 with full support for the latest Monterey Beta 8 (21A5534d)

Update Includes:
  • Lilu v1.5.6
  • AppleALC v1.6.5
  • RestrictEvents v1.0.5
  • VirtualSMC v1.2.7
  • WhateverGreen v1.5.4
  • Switched from OpenHfsPlus.efi to HfsPlus.efi (Reliability)
  • OpenShell moved to Auxiliary
  • Removed SMCAMDProcessor kext. (User Choice. Available here, https://github.com/trulyspinach/SMCAMDProcessor )
As with each release remember to check the kernel patch is set for your CPU: More Info Here!
Clear the NVRAM once updated. (Press the Spacebar at OpenCore Picker to show option.)

 
Last edited:

daovietchung

New member
Joined
Sep 27, 2021
Messages
2
Hi @Shaneee ,
Thank you for sharing the files to successfully install Hackintosh.
But now I am suffering from a problem with using bluetooth. Looks like it's not working. I also use wifi card and adapter like yours.
Can you share a picture of the connection wire from the wifi card to the mainboard. I need to know for sure where to plug in the internal USB ports. Maybe this is the problem.
I tried running on Windows 10, both wifi and bluetooth work fine.
Thank you very much.

 
Last edited:

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
@daovietchung It should work in either of the two USB 2.0 headers on the bottom of the board. I'm using a NZXT hub as I needed more 2.0 ports.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Try with this kext,
 

Attachments

  • USBMap.kext.zip
    2 KB · Views: 8

palote99

Donator
Donator
Joined
Oct 19, 2021
Messages
3
Hi Shaneee,

Thanks for you complete work!
.. Im noob atm and i get this error when booting...

How i can disable openlinuxboot.efi from config.plist?

Thanks in advance!
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Hi Shaneee,

Thanks for you complete work!
.. Im noob atm and i get this error when booting...

How i can disable openlinuxboot.efi from config.plist?

Thanks in advance!

In the config under UEFI -> Drivers either set OpenLinuxBoot to disabled or remove the entry.
 

palote99

Donator
Donator
Joined
Oct 19, 2021
Messages
3
In the config under UEFI -> Drivers either set OpenLinuxBoot to disabled or remove the entry.
Thanks! I managed to do that.. but now when i boot fron usb i get a windows icon and nothing else... I dont get into any MacOS installer
My boot-args are -v keepsyms=1 debug=0x100 alcid=1

Please help!!
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Thanks! I managed to do that.. but now when i boot fron usb i get a windows icon and nothing else... I dont get into any MacOS installer
My boot-args are -v keepsyms=1 debug=0x100 alcid=1

Please help!!

Sounds like the installer is incomplete or damaged. Remake the USB but still use the EFI.
 
Top Bottom