Ryzen 9 3950X, ASRock X570 ITX/TB3, AMD Radeon VII, Catalina

ftln

New member
May 2, 2020
17
7
3
Build
CPU: AMD Ryzen 9 3950X
Mainboard: AsRock X570 Phantom Gaming ITX/TB3 (BIOS 2.0)
Memory: Corsair Vengeance RGB Pro (PC4-28800) C18 64 Go (2x32 Go) CMW64GX4M2D3600C18
Storage: 2 x SKhynix SC300 HFS512G32MND-3210A 1 x PM981 NVMe Samsung 512GB (PM981 Disabled in opencore when to booting MacOS)
Video Card: AMD Radeon VII 16Gb HBM2
Power Supply: Corsair AX760i
Case: NZXT MANTA (White)
Thunderbolt3: QNA-T310G1S (10gb/s SFP+)

Working
Audio
GPU
LAN
Shutdown
USB
DisplayPort In
Bluetooth
Sleep
TB3

SMBIOS
MacPro7,1

Known issues
Thunderbolt without hot-plugging (devices need to be connected before boot but works fine as USB-C)
After restart bluetooth does not work, workaround is to not restart and do a shutdown instead.

EFI
For more background and EFI check out the Github repo: RyzenMacPro

Notes
Still trying to figure out to get native HEVC HW Acceleration with the Radeon VII in Catalina 10.15.4 without using WhateverGreen.kext

Benchmark
My build vs True 2019 MacPro https://browser.geekbench.com/v5/cpu/compare/1998579?baseline=2001400

pvS2NBjSDaZu7O-x2Z1n7Uxax6PEz2O12ImPioopI0FI8sGGrcQjlAsm5cBBDZUl_dDOWWZo1JVYPrBjH52hHcp-pDU23V...jpg
 

Aluveitie

Active member
May 2, 2020
301
67
28
Certain Apps working/not working has nothing to do with individual builds. Xcode does mostly work on AMD except for Watch Simulator. Adobe needs patching for all AMD CPU unless you use Virtualization.
 
  • Like
Reactions: Technomad