Ryzen 9 3900x | Gigabyte X570 Aorus Pro WiFi | Gigabyte 5700XT | OC 0.5.8 | Catalina 10.15.4

hayskeys

New member
May 13, 2020
2
3
3
Got inspiration and install tips from the posts made by Niko and freeubi. Followed the Vanilla guide and many hours pouring over the exact details of the OpenCore guide linked in the Vanilla guide. A huge thank you to all of you đź‘Ź.

Hardware
CPU: AMD Ryzen 3900X
MOBO: Gigabyte X570 Aorus Pro WiFi ATX
RAM: 64GB (4x16) Corsair DDR4 3600 RGB
GPU: Gigabyte RX 5700XT Gaming OC 8G
SSD: Samsung 1TB 970EVO+ NVME M.2 SSD (x2, 1 for MacOS, 1 for Windows 10)
PSU: Thermaltake 750W Toughpower Gold
CASE: NZXT H510 Elite

Software
OpenCore 0.5.8
MacOS Catalina 10.15.4
1589501845183.png

Config
MacPro 7,1
ACPI: SSDT-EC, SSDT-USBX (used SSDTTime to dump DSDT on Windows then build SSDT-EC, and grabbed pre-built SSDT-USBX from the OpenCore guide)
Drivers: HfsPlus, OpenRuntime
Kexts: Lilu, VirtualSMC, AppleALC, MacProMemoryNotificationDisabler, SmallTreeIntel82576, WhateverGreen, AMDRyzenCPUPowerManagement, SMCAMDProcessor
Boot-args: -v keepsyms=1 debug=0x100 agdpmod=pikera
Screen Shot 2020-05-14 at 7.14.18 PM.png

BIOS
Fast Boot: Disabled
CSM Support: Disabled
Above 4G Decoding: Enabled (hence no npci=0x2000 boot-arg)
XHCI Hand-off: Enabled
SATA Mode: AHCI
System Memory Multiplier: 36.00 (I set this after install when I noticed RAM was running at 2133. This set it to the spec'd 3600MHz.)

File System Format
APFS + GUID (I decided against any of the Encrypted / Case-sensitive options)

Benchmarks
Geekbench 5 CPU: https://browser.geekbench.com/v5/cpu/2160907
Geekbench 5 Compute: https://browser.geekbench.com/v5/compute/916618
Untitled_3.png

Known Issues
Sleep
Very occasional system jitters. Usually a 1-2 second stall where mouse works fine, but chrome or other app will stall out.

Notes
This is my second Hackintosh but my first one running AMD or OpenCore. This is already clearly far more stable than my old Intel build from 2014. Awesome to see how far it has come and how much amazing work the Hackintosh community has put in.
I'm using this machine mainly for audio mixing work with Logic Pro. Using a Focusrite 2i4 to drive speakers and some basic inputs.
System runs like a charm.
 

Attachments

Last edited:

blacksnow

New member
May 13, 2020
1
1
3
@hayskeys Noob here, looking to build a very similar machine. Just curious about a few things:
  • Does Bluetooth work? (mice, keyboards, etc)
  • Does Airdrop work?
  • Do iServices work?
  • Are you using on-board audio?
  • Did you install windows first or macOS?
  • What Cooling are you using for your CPU and case?
  • Lastly, this question isn't that important, but I'm just curious about the RGB on the board and GFX card. Does the RGB work? Do you have to set it up in windows using the Fusion 2.0 app or the BIOS, and if so, do the colours/patterns stay the same when you boot into macOS? This isn't a deal breaker, but I've been curious as to the customizability of RGB in a hackintosh build.

Cheers!
 
  • Like
Reactions: ToBeTechnical

Niko

New member
May 17, 2020
2
0
1
I was about update my OC install; then saw yours. So I pinched it! (Thank you)
Did you buy your hardware based on my specs or was it a coincidence?
Everything is exactly the same but the sub-brand of 5700xt

Also I recommend you run XMP Profile for your RAM instead or use Ryzen Memory Overclocking Tool.
 
Last edited:

pozo

New member
May 24, 2020
1
0
1
Thanks for posting.
I copied your files and everything works fine, besides changing serial number stuff and machine type, since my video card is GT 710.

One issue I have is the hard drives are shown as external drives. Any idea how to fix that?
 

mariusing

New member
Jun 21, 2020
1
0
1
I am using the same Mobo but with 5500xt iso 5700xt, I didn't managed to get into the installer without graphics glitches, will try your EFI to see if it works
 

rx3700

New member
May 3, 2020
14
1
3
@hayskeys
  • Lastly, this question isn't that important, but I'm just curious about the RGB on the board and GFX card. Does the RGB work? Do you have to set it up in windows using the Fusion 2.0 app or the BIOS, and if so, do the colours/patterns stay the same when you boot into macOS? This isn't a deal breaker, but I've been curious as to the customizability of RGB in a hackintosh build.
Using the ITX version of this board, the RGB settings for the board work in OSX as well, Wraith Prism Cooler too, BUT: You should not expect great results with other RGB components (such as RAM) which rely on software. Those will go back to default on OSX unless you boot Windows first. As for the Windows Dual Boot, you can find a detailed description in my setup.
 

someone

New member
Jun 21, 2020
6
0
1
Yeah, thank you for sharing that EFI/OC folder. Got my ITX Gigabyte X570 AORUS I PRO WIFI working with it :)
Only problem which i do have is the internal Bluetooth. It's enabled in Catalina, but cannot be disabled and does not find any device.
So my questions:
a) How can i make it work?
b) which KEXTS do i have to remove so that i can conect an external BT dongle?

Thank you!
 

someone

New member
Jun 21, 2020
6
0
1
Okay the firmware did not change anything at all.
How can i disconnect the internal USB?
 

olbo

New member
Jun 26, 2020
24
11
3
Option C would be to disable it with a custom SSDT and buy something like a T919. I can upload the patch tomorrow
 

igerry

New member
Jun 25, 2020
12
3
3
I am using the same Mobo but with 5500xt iso 5700xt, I didn't managed to get into the installer without graphics glitches, will try your EFI to see if it works
I have the same board and I am using 5500xt, you can try motherboard bios version F11 to get rid of graphics glitches.