Ryzen 3700X, MSI B450m Mortar Max, MSI Radeon RX5700 MECH OC, Catalina 10.15.4 / OC 0.5.8

Hackindan

New member
Joined
May 7, 2020
Messages
2
After tens of retries and premature reboots when originally loading the OS, I finally found a workaround that allowed me to successfully boot into my new Catalina install.

My installation was getting stuck on 2 minutes then rebooting. Then, when I tried to boot into Catalina, it would show an error on the “Installer Log”.

The fix is to get to this point of the process, then get access to a Mac. On the Mac download newest Catalina & install to a USB (took an hour or so) much slower than SSD obviously so make sure your Mac has lots of battery!

Once completed, clone the USB Catalina install to your Hackintosh via your original USB boot drive then in disk utility (make sure partition formats are the same APFS).

Once installed, shutdown, remove all USB boot drives and Catalina will boot.

TL;DR: you didn’t f up. It’s just a bug that restarts after 2 mins, I think it’s the 5700 GPU causing this (despite all the boot args I tried no concoction worked). Clone a new install via USB and boot. Problem solved!
 

christopheruv

New member
Joined
Jun 1, 2020
Messages
1
Thats great! Which AppleALC codec id are you using for your mobo in the boot args? I have an MSI b450 pro m2 v2 and I tested various alcid=x bootflag but it doesnt work.
I only have sound with VoodooHDA.kext
 
Top Bottom