Red Screen Monterey amd installation

geovane

New member
Joined
May 15, 2022
Messages
8
Hello guys,
I want to install monterey on amd pc. I have followed several tutorials. But I always stop at a red screen with "X64 expectation error". follow my pc specs.

Mb: Asus m5a78l-m lx/br
Cpu: Amd fx 6300
Gpu: R9 270X




 

Attachments

  • opencore-2022-05-22-220700.txt
    256 KB · Views: 0

geovane

New member
Joined
May 15, 2022
Messages
8
Olá pessoal,
Eu quero instalar o monterey no amd pc. Tenho seguido vários tutoriais. Mas sempre paro em uma tela vermelha com "erro de espera X64". segue as especificações do meu pc.

Mb: Asus m5a78l-m lx/br
Processador: AMD FX 6300
GPU: R9 270X




 

Attachments

  • EFI.zip
    7 MB · Views: 1

Edhawk

Active member
Joined
May 2, 2020
Messages
686
Are you using OpenCore Legacy mode/boot option? I had to use Legacy boot file with my FX6300 system.
 

geovane

New member
Joined
May 15, 2022
Messages
8
Você está usando o modo/opção de inicialização do OpenCore Legacy? Eu tive que usar o arquivo de inicialização Legacy com meu sistema FX6300.
Sim. Meu mb tem a bios legada. Eu criei a inicialização herdada com núcleo aberto. Tentei usar a unidade hfsplusLegacy e depois hfsplus, mas também não funcionou
 

Attachments

  • WhatsApp Image 2022-05-22 at 22.19.36.jpeg
    WhatsApp Image 2022-05-22 at 22.19.36.jpeg
    268.2 KB · Views: 6

Edhawk

Active member
Joined
May 2, 2020
Messages
686
Sim. Meu mb tem a bios legada. Eu criei a inicialização herdada com núcleo aberto. Tentei usar a unidade hfsplusLegacy e depois hfsplus, mas também não funcionou
Translated: Yes. My mb has legacy bios. I created the legacy boot with open core. I tried using the hfsplusLegacy drive and then hfsplus but it didn't work either.

Are you sure you used the correct Legacy Tool, as there is an x64 and an IA32 tool in the LeagacyBoot folder. You need to be using the X64 tool, highlighted below, when setting the EFI as OC Legacy.

Screenshot 2022-05-23 at 20.06.15.png OpenCore-0.8.0/Utilities/LegacyBoot folder contents, with x64 tool highlighted
 

geovane

New member
Joined
May 15, 2022
Messages
8
Translated: Yes. My mb has legacy bios. I created the legacy boot with open core. I tried using the hfsplusLegacy drive and then hfsplus but it didn't work either.

Are you sure you used the correct Legacy Tool, as there is an x64 and an IA32 tool in the LeagacyBoot folder. You need to be using the X64 tool, highlighted below, when setting the EFI as OC Legacy.

View attachment 5934 OpenCore-0.8.0/Utilities/LegacyBoot folder contents, with x64 tool highlighted
I used this one from X64. What is the motherboard of the pc that made the hackintosh?
 

geovane

New member
Joined
May 15, 2022
Messages
8
Translated: Yes. My mb has legacy bios. I created the legacy boot with open core. I tried using the hfsplusLegacy drive and then hfsplus but it didn't work either.

Are you sure you used the correct Legacy Tool, as there is an x64 and an IA32 tool in the LeagacyBoot folder. You need to be using the X64 tool, highlighted below, when setting the EFI as OC Legacy.

View attachment 5934 OpenCore-0.8.0/Utilities/LegacyBoot folder contents, with x64 tool highlighted

Using Oc debug shows "failed to get frequency data from fsb using Apple's platform information - not found"
 

Edhawk

Active member
Joined
May 2, 2020
Messages
686
Try this revised EFI see if it gets you any further.
 

Attachments

  • EFI.zip
    3.6 MB · Views: 2
Top Bottom