Problems by installing Catalina.


New member
Jun 19, 2020
Hello there folks,

Im having trouble installing Catalina on my PC.

AMD Ryzen 2600x
Sapphire RX580 8gb Special Edition
Gigabyte Aorus B450m Mainboard
16GB DDR4 TridentZ RAM
Samsung 860 QVO SSD
Seagate Barracuda HDD
I set up a Catalina Install on my USB with OpenCore all fine and running,the main problem is I cant continue the installation because Catalina needs internet,somehow I can not find any kext that works with my Ethernet adapter. I have a Realtek 8118 Gaming lan? I tried various 8111 versions but none of them worked. Can anybody help me with this ? Is there a LAN card that works straight outta box? Or a dongle or something ? I dont want to spend more than 50 bucks on this.


New member
Jun 18, 2020

I tried use all of kext to raltek or diffrent one, i added them to kext folder and boot to macOs installer but its dont working.
You must add new kext to your folder on bootable USB and use ProperTree-master or different .plist menager and make OCsnapshot and then boot to macOS installer.
I think i used the latest version on Realtek8111, it should work on you pc.
Good luck!
Top Bottom