No sleep and shut down restarts

savage001

Active member
Joined
Jun 4, 2020
Messages
135
So after a while of being away (no monitor) I’m back and I’ve updated to newest 11.4 beta 1, latest clover and kexts.
I believe I used to have sleep working but now it either instant wakes or wakes after a short period. While it does sleep for the short period my ram leds stay on as well. Also when I shut down macOS my rig reboots instead. Specs should be in signature.
USB ports are mapped correctly I think. No custom dsdt.

My new monitor has built in kvm so it’s attached via USB type c to my pc and display port. Could the kvm be causing the wake issues? Keyboard and mouse are plugged into the monitor.

Latest bios for my board
X570 AORUS PRO WIFI F33h.


Sent from my iPhone using Tapatalk
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
The memory has to stay on while the system is in a sleep state so if you have RGB Ram then that’s totally normal to see it lite up while sleeping. Some motherboards have the option to turn that off via the bios but not the X570 Pro im afraid.
Power sleep will cause your system to wake up in its own to make checks to your Mail, iCloud, photo steam etc etc.
If you uncheck power sleep in system preferences then that will stop too. Wake for network is also a cause of random wakes from sleep so uncheck that too.

As for not shutting doan...Make sure you have ERP Disabled in the bios and there’s a usb setting in there that causes that too problem but I can’t remember off the top of my head the setting name....
Il update when I remember...lol
 

codecex

New member
Joined
Nov 30, 2020
Messages
5
im in the same problem, still looking for a workaround, if i shutdown, systems restarts instead of power off, with a X570 aorus elite and ERP disabled, if you find the correct usb setting to change in BIOS please, let me know, thank you!
 

tatofuma

New member
Joined
Jan 20, 2021
Messages
25
im in the same problem, still looking for a workaround, if i shutdown, systems restarts instead of power off, with a X570 aorus elite and ERP disabled, if you find the correct usb setting to change in BIOS please, let me know, thank you!
Same mobo and same problem for me. I try a lot of bios settings, nothing resolved
 

WckedCode

New member
Joined
May 24, 2021
Messages
3
Same problem as you guys and same Mobo (mine is mini itx) with same BIOS (33h). Still looking for a solution...
 

Bansaku

Member
Joined
May 3, 2020
Messages
43
im in the same problem, still looking for a workaround, if i shutdown, systems restarts instead of power off, with a X570 aorus elite and ERP disabled, if you find the correct usb setting to change in BIOS please, let me know, thank you!
Same mobo and same problem for me. I try a lot of bios settings, nothing resolved

Hey guys, I have an X570 Elite and everything works 100% with zero issues with sleep. Here is my EFI folder for you to try (minus the S/N). Hope this helps.
O.C. 0.6.9
BIOS 33h
The only changes I made to the BIOS after loading optimized defaults was enabling XMP and selecting Mac OS as the boot drive.
 

Attachments

  • EFI.zip
    15.8 MB · Views: 3

WckedCode

New member
Joined
May 24, 2021
Messages
3
Hey guys, I have an X570 Elite and everything works 100% with zero issues with sleep. Here is my EFI folder for you to try (minus the S/N). Hope this helps.
O.C. 0.6.9
BIOS 33h
The only changes I made to the BIOS after loading optimized defaults was enabling XMP and selecting Mac OS as the boot drive.
Will compare both later and give yours a try and will report here if anything changes.

Thanks for help!

PS: didn't work, main difference was the darkwake boot arg but no luck :/
 
Last edited:
Top Bottom