No Metal support

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
The PAT patch is the last two kernel patches. My patch boosts AMD GPU performance.

How is it you're testing metal support?
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
I'm assuming you've got Whatevergreen.kext? If you do, add the boot arg radpg=15. I'm unsure if it'll help but worth a try.
 

Edwin

New member
Joined
Jul 25, 2021
Messages
24
Shoot, it doesn't work. Is the position where I put "radpg=15" of any importance? I put it at the very end: "keepsyms=1 npci=0x3000 msibase=0x90 alcid=2 -no_compat_check debug=0x100 radpg=15"
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Position doesn't matter no. What is msibase=0x90 for though? Also if you need to use -no_compat_check then you're using the wrong SMBios.
 

Edwin

New member
Joined
Jul 25, 2021
Messages
24
Position doesn't matter no. What is msibase=0x90 for though? Also if you need to use -no_compat_check then you're using the wrong SMBios.
I don't know, so I deleted it. Both by the way and no issues booting MacOs. But Metal is still not working.
 

Edwin

New member
Joined
Jul 25, 2021
Messages
24
When I check my config.plist in OCC I see this:
SSDT-EC-USBX-DESKTOP.aml don't use both SSDT-EC-USBX-DESKTOP and SSDT-EC
SSDT-EC.aml
don't use both SSDT-EC-USBX-DESKTOP and SSDT-EC
You might need something like SSDT-EC.aml or SSDT-EC-USBX-DESKTOP.aml. See the [ACPI Docs].
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Only use SSDT-EC-USBX-DESKTOP.aml but this wouldn't affect the GPU. Does YouTube etc play at all?
 

Edwin

New member
Joined
Jul 25, 2021
Messages
24
Only use SSDT-EC-USBX-DESKTOP.aml but this wouldn't affect the GPU. Does YouTube etc play at all?
Yes, YouTube plays without any hiccups. I wonder if I delete everything but the ssdt you mention, will it boot then?
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
What I meant is that you shouldn't use two different EC SSDTs. If YouTube plays without any issues I don't thing there's actually an issue with the GPU working. Just a cosmetic thing.
 

Edwin

New member
Joined
Jul 25, 2021
Messages
24
What I meant is that you shouldn't use two different EC SSDTs. If YouTube plays without any issues I don't thing there's actually an issue with the GPU working. Just a cosmetic thing.
Ok, it plays 4K video flawlessly also.
 
Top Bottom