New Nvme drive shown as external

Tyoma

Donator
Donator
Joined
Mar 1, 2021
Messages
22
Hey all!
I had one WD_Black nvme drive with Big Sur installed on it, and regular SSD with windows for dual boot.
I bought another nvme to move windows to it (I have 2 nvme slots) but now the new one is shown as an external drive..
Any way to fix it?

Screen Shot 2021-07-02 at 11.15.15.png
 

clover84

New member
Joined
May 16, 2021
Messages
8
Hey all!
I had one WD_Black nvme drive with Big Sur installed on it, and regular SSD with windows for dual boot.
I bought another nvme to move windows to it (I have 2 nvme slots) but now the new one is shown as an external drive..
Any way to fix it?

View attachment 3496
Hi!
1. Look for you Device Path using Hackingtool (in PCIe section, Class should be Mass storage controller → Non-Volatile memory controller)
2. Copy Device Path
3. Add a new dictionary to your config.plist in Device Properties → Add as shown on the screenshot
4. Create a record:

name: built-in
type: Data
value: 01000000

Should fix the issue.

 

Tyoma

Donator
Donator
Joined
Mar 1, 2021
Messages
22
Hi!
1. Look for you Device Path using Hackingtool (in PCIe section, Class should be Mass storage controller → Non-Volatile memory controller)
2. Copy Device Path
3. Add a new dictionary to your config.plist in Device Properties → Add as shown on the screenshot
4. Create a record:

name: built-in
type: Data
value: 01000000

Should fix the issue.


Thanks!

Screen Shot 2021-07-05 at 16.54.43.png
 
Top Bottom