Need help : No sound but sound control is active

speedytest

New member
Joined
Dec 7, 2020
Messages
4
Hello,

I have followed a lot of tutorials but I never find the solution for my problem.

I have no sound but gesture and output option are activated.

I can have the sound only on my HDMI screen but when I'm selecting the internal speakers, I have no sound, and it's the same problem on line out. I can up or down the volume but no sound comes out of my speakers.

Tried with the CSM enabled or disabled in the bios, same problem.
I Configured my bios like this:
  • EHCI Handoff -> Enabled
  • XHCI Handoff -> Enabled
  • Serial and Parallel ports -> Disabled
  • SATA Port -> AHCI
  • CSM -> Disabled
  • Secure Boot -> Disabled
The alcid is set to 1 into the bootargs.

My configuration is :
  • Ryzen 9 3900XT
  • TUF GAMING B550-PLUS with Realtek ALC S1200A
  • RX580 Strix

I attached my EFI folder.

Can anyone help me ? Thanks in advance :)


EDIT:
When sound is at the maximum, I can ear cracks in the sound but only at sound spikes.
 

Attachments

  • EFI.zip
    3.7 MB · Views: 3
Last edited:

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
You could try this.
 

speedytest

New member
Joined
Dec 7, 2020
Messages
4
You could try this.
OMG, the sound is ok now, but if I understood correctly, this guide do not enable the onboard mic, I can't use a microphone on the front or the rear of my case. Only headphone is enable on the rear and front of my case.
 

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
OMG, the sound is ok now, but if I understood correctly, this guide do not enable the onboard mic, I can't use a microphone on the front or the rear of my case. Only headphone is enable on the rear and front of my case.
Microphone in is not working but a USB mic or webcam should.
 

speedytest

New member
Joined
Dec 7, 2020
Messages
4
Microphone in is not working but a USB mic or webcam should.
If you want my configdata is :
<01771C00 01771D00 01771E17 01771F40 01471C10 01471D40 01471E01 01471F01 01470C02 01671C11 01671D60 01671E01 01671F01 01571C12 01571D10 01571E01 01571F01 01B71C20 01B71D40 01B71E21 01B71F02 01B70C02 01E71C40 01E71D61 01E71E45 01E71F01 01871C50 01871D90 01871EA1 01871F01 01A71C5F 01A71D30 01A71E81 01A71F01 01971C60 01971D90 01971EA1 01971F02 01171CF0 01171D11 01171E11 01171F41>

Thanks again for your tutorial :)

Have a nice day
 

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
If you want my configdata is :
<01771C00 01771D00 01771E17 01771F40 01471C10 01471D40 01471E01 01471F01 01470C02 01671C11 01671D60 01671E01 01671F01 01571C12 01571D10 01571E01 01571F01 01B71C20 01B71D40 01B71E21 01B71F02 01B70C02 01E71C40 01E71D61 01E71E45 01E71F01 01871C50 01871D90 01871EA1 01871F01 01A71C5F 01A71D30 01A71E81 01A71F01 01971C60 01971D90 01971EA1 01971F02 01171CF0 01171D11 01171E11 01171F41>

Thanks again for your tutorial :)

Have a nice day
Yes I will update, Please list the motherboard completely so others can match.
 
Top Bottom